3

I used to index my NAS with the command line mdutil -i on. Ok, I know it's not perfect, but it worked for me.

But since I updated to macOS Sierra it's not working anymore. If I type mdutil /Volumes/name -i on I just get the feedback Indexing disabled. It doesn't matter if I use SMB or AFP (SMB was always working for me).

Maybe this information is helpful for a solution, if I mdutil /Volumes/name -E I get the feedback: mdutil disabling Spotlight: /Volumes/archiv -> kMDConfigSearchLevelFSSearchOnly. Indexing disabled.

Does anyone has any solution?

  • Presumably mdutil -s -a -v shows indexing and searched disabled for the NAS volume? Also does man mdutil show any restrictions on enabling using -i that might be new to Sierra? (I'm on El Capitan and it doesn't list anything, but it could have changed.) – tubedogg Oct 30 '16 at 19:21
  • mdutil -s -a -v just shows "indexing disabled" for the (the share). Before i was on Yosemite and it worked fine. – aktivomat Oct 31 '16 at 12:18
  • 1
    I came here looking for a solution and found your question. It seems to be a problem with Sierra+ itself, since Yosemite was working perfectly fine for me as well. :\ – Reda Lazri Feb 28 '17 at 20:09
  • Also looking for a solution to this.. If your NAS is one you've built yourself (a linux box) then you can apparently compile Samba with spotlight support using tracker but I haven't tried it. – py4on Mar 12 '17 at 13:30
  • Same here since Sierra. – Marc May 18 '17 at 14:47
5

According to this support page by Qumulo, there is a fix, which basically consists of the following:

To fix this issue, create the following directory as root:

sudo mkdir -p /private/var/db/Spotlight-V100/Volumes/

And then re-enable Spotlight indexing of that Volume:

sudo mdutil -i on /Volumes/name_of_your_volume

I haven't tried it myself, but I thought it's worthwile to mention it here.

  • 1
    Thank you! I was getting Index disabled after each run of mdutil -i on a SMB volume. Creating that directory solved my problem. – Brendonwbrown Sep 11 '17 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .