2

Since upgrading to Sierra and iOS 10, both my Mac and iPhone find an AirPlay device named "Apple TV (2)". The thing is, I don't own an Apple TV. Selecting the phantom device always results in "Could not connect to “Apple TV (2)”".

This is on my home Wi-Fi network, which is definitely locked down (and I can see from AirPort Utility that there's only these 2 Wi-Fi clients on it). I've also noticed this problem occur on some other Wi-Fi networks.

I have a MacBook Pro running Sierra 10.12.1 GM (latest), iPhone 6s running iOS 10.0.2 GM (latest), and a 5th gen (current) Time Capsule with firmware 7.7.7 (latest).

Yes, I have rebooted all three devices.

I've even done a clean install of Sierra (following http://www.macrumors.com/how-to/macos-sierra-clean-install/) and created a clean user account. The problem reproduces across user accounts.

I'm clearly hitting a bug somewhere, but I wonder why more people aren't hitting this problem? Any ideas on how I can further debug this? I don't see anything relevant in Console logs, but perhaps I'm not looking in the right place.

enter image description here enter image description here enter image description here enter image description here enter image description here

  • I'd start by updating the iPhone to iOS 10.1. – tubedogg Oct 30 '16 at 19:28
3

Apparently I'm seeing a neighbor's Apple TV via peer-to-peer AirPlay. So they're not on my Wi-Fi network but don't have to be.

This is annoying. Now I'd like to know how to disable this (it's particularly annoying when trying to change the volume via the menu extra since the slider moves from under my mouse after a second), but it seems impossible to disable this mis-feature.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .