19

Today I got an event request from a "fake ray ban" scammer/seller for my iCloud calendar. The calendar is shared/synced with my iPhone via iCloud.

Unfortunately, when I pressed delete, the calendar popup told me that deleting the event means also I'll decline it and the sender will be notified.

I want to remove the event without notifying the sender, because the event is sent to many other generated email addresses and I don't want confirm my address by declining the event.

This is a very serious Calendar privacy problem. If there isn't an simple solution it is enough reason for me stopping using Apple's calendar.

So, how do I remove the event from my notebook's calendar, my iCloud-synced iPhone's calendar, without notifying the sender?

8

I found this free workaround over on Superuser.

Basically, you disable networking, delete the event, then delete the notification from email:

  1. Turn off networking on your Mac
  2. Delete the event from iCal
  3. Wait for the notification to show up in your Outbox
  4. Delete email from Outbox
  5. Turn back on networking

Once networking is back on, the sync will remove the other events from iCloud and your phone.

Echoing Jaime Santa Cruz's comment below, you should definitely block the sender. You have already confirmed your email because it (probably) already sent a notification that you accepted; best to be safe and not sorry.

As to your second question, "...it is enough reason for me stopping using the insecure Apple's calendar?" it would generate too much opinion to go into.

That said, I personally use Office365 Exchange Online ($48 for the year), Outlook.com, OneDrive and Azure for my cloud services with my iMac, MacBook Pro, XServe and (soon) a refurbished Mac Pro. I don't know if that says anything...

  • 2
    Also, look for the invite on your email and block the sender. – Jaime Santa Cruz Oct 30 '16 at 15:01
  • Seems like this should be possible without the workaround. But I suppose given that you've already sent an acceptance, this limitation (sort of) makes sense. On a related note—just curious—can you accept a calendar invitation in the first place without sending a notification? – Wildcard Oct 30 '16 at 15:50
  • 2
    What a ridiculous workaround for something that's a default option on Gmail and Microsoft Exchange – ecnepsnai Oct 30 '16 at 15:50
  • Accepting the only and most upvoted answer, but can't test it because i disabled my Calendar. – jm666 Nov 3 '16 at 12:57
5

I had a similar issue but with a repeating event sent in Chinese script. The event repeated every day indefinitely and there was no option to delete without sending a delete confirmation to the Sender.

A bit of digging revealed that this is likely an invite sent directly to the iCloud calendar.

To try to stop this I have set that calendar invite to "Email" (you need to do this on the web icloud calendar options Setting>Preferences>Advanced>Invitations>EmailTo). Hopefully, nothing will be inserted into my calendar now without me accepting.

To remove the offending event, I created a Spam calendar on iCloud Calendar on the Web, moved the event to the Spam Calendar (on my mac), then deleted the Spam calendar (again, on the Mac).

Everything now seems to be in order.

  • 2
    @Brick - his answer does answer the OP's question - create a "spam calendar and move the event there" - which presumably doesn't notify the sender. Perhaps a request to clarify rather than a down vote? – Allan Nov 6 '16 at 10:55
  • Rephrased: Is there a way to remove this calendar event without notifying the sender? @Allan: Ok. I just feel that there has already been a better answer which answers what the OP wants, and this answer is not as good. Thanks. – Brick Nov 6 '16 at 13:18
  • "...moved the event to the Spam Calendar (on my mac).." Could you elaborate on how you did this? I'm unable to move the appointment using Calendar on my Mac. When I click on the little colored square representing the calendar, from the appointment details, I don't see choices for other calendars. If I drag it to the calendar listing on the lefthand side, it copies, but does not move, the appointment. – Dave Munger Sep 5 at 16:45
  • Also, if I right-click on the appointment summary and then hover over "Calendar" from the popup menu, all the other calendar choices are listed, but disabled and cannot be chosen. – Dave Munger Sep 5 at 16:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .