7

My config: Mid 2012 Mac mini connected to a projector via HDMI. The projector is typically off and the Mac mostly works headless.

This setup has worked for me for a couple of years now. Ever since I upgraded to Sierra (10.12.3), I get only a black screen with the mouse pointer being visible though. When I log out (cmd+shift+q), I sometimes get an image but it does not really update and is displaced.

enter image description here

Once I turn the projector on, screen sharing will also start working – even if I turn the projector off again. SSH always works without issues.

Any clues how I can fix that?

What I tried (will update):

Update 1: This seems to be a related Apple Discussions thread.

Update 2: I added an answer that gives some hints. Can anyone help me find a better solution, please? My guess is the GPU has to be force enabled somehow, e.g. in bash...

  • 1
    I'd try SwitchRes and see if that helps, as it can mess with the available screen parameters. Alternatively, there are some other tools simulating or inserting screens that may help, such as AirDisplay and related apps. It may also help to add another video connector for a VGA or DVI display to fool the Mac into thinking there's an active display connected (oh, I see you already mention that in your answer). – Thomas Tempelmann Mar 10 '17 at 10:40
  • @ThomasTempelmann Thank you for that. Using SwitchRes did not cross my mind yet. I will give it a try later today... Maybe I should ask another question on how to force enable the GPU. – n1000 Mar 10 '17 at 10:43
  • What makesyou think it has something to do with the GPU (I guess your Mac has both a simply graphic processor on the Intel CPU and a dedicated high-performance one, for games and such? I only know that from my MacBook Pro, my older Minis don't have that.) – Thomas Tempelmann Mar 10 '17 at 10:48
  • That is what I gathered from the other discussions. Also the fact that the "dongle trick" works hints at that. This mac mini has only one GPU. – n1000 Mar 10 '17 at 11:05
  • Okay, then asking for "force-enabling the GPU" won't get you anyway, I believe. The hardware trick works because the GPU senses the line and therefore lets the OS know that there's a monitor, and then the OS activates the GPU. But whether the GPU is active or not may not be relevent to Screen Sharing. Instead, The OS needs to think there's a display. Just activating the GPU somehow would not make the OS think that. You'd only get irritated responses for that question, I think :) It's all about making the OS believe there's a monitor connected. Hence AirDisplay etc, which can do that. – Thomas Tempelmann Mar 10 '17 at 11:13
6

These are solutions that I found but that do not work for me:

  1. UPDATE: The issue finally and miraculously disappeared after updating to macOS 10.12.4.

  2. If you run third party applications, such as AirParrot or f.lux, you should try completely uninstalling those, as discussed here.

  3. If your mac is 100% headless (i.e. no screen attached), you can either add an HDMI dongle or hack your own Thunderbolt dongle using a VGA adapter. This is a common trick to activate the GPU and comes with the added benefit that Screen Sharing gets much faster. This actually works for me, but is not a permanent solution to my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .