This morning I had the same Issue as in this thread. I had 7 Updates, but the "Updates" tab was empty. The "solution" seemed to be updating on the "Purchased" tab.

But my tab says, that I haven't purchased any apps yet.

enter image description here

I am logged in....

enter image description here

I moved from Germany to America. But I have downloaded several Updates for Xcode in Germany, as well as in America.

I have changed my "Country and Region" to the States. And I just have tried to change it back. The tab stays empty.

I want to update to Xcode 8.1

Now I'm downloading Xcode as if it would be a complete new app. It asked me to "get" instead of "update" Xcode...

Even tho I have it installed.

enter image description here

I have tried to switch back to the German Store by changing back my "Country and Region". And I have restarted my MacBook 100 times. Also, I only use this one AppID.

First Xcode download was in Germany a year ago. But update to macOS Sierra, what also brought me Xcode 8 was with this Account and with the US App Store... So it should not be a matter of Country/Region...

PS: The updates issue is gone since I have activated Auto Update.. I have no pending updates anymore.

enter image description here

But Xcode is still in Version 8.0 and I'm able to "download" (get) Xcode 8.1 from the store.

  • I CAN SEE YOUR APPLE ID ACCOUNT THROUGH THE RED MARKER. – Bradman175 Oct 28 '16 at 12:32
  • @Bradman175 updated. thanks for the hint mate – David Seek Oct 28 '16 at 12:34
  • (I've seen this happen in many situations...) – Bradman175 Oct 28 '16 at 12:35

The App Store is having problems since yesterday afternoon. It is not your fault, it is a problem on their end. So we just have to wait it out.

  • The App Store is back now. – GEdgar Oct 28 '16 at 14:34
  • well. i have finished downloading the "new app xcode"... but still my purchased tab says I havent downloaded anything. even THO i just said: I have finished downloading xcode (with "get") – David Seek Oct 28 '16 at 18:33
  • and yes, i have restarted my macbook – David Seek Oct 28 '16 at 18:33

I had the same issue. I found an answer that got me some help: "there is a commandline app called softwareupdate that you have to run as root.

sudo softwareupdate --list for example will give you the list of apps that are set to update. You can then run sudo softwareupdate --install {app-name}

This won't let you install a new application that you haven't already downloaded though.

shareedit answered Nov 20 '12 at 20:08

Mark Cohen 63646" Using Mark Cohen's suggestion, I updated iTunes by command line and today my App Store App is up to date.

  • I ran softwareupdate at terminal, but it only installed itunes and sierra update. not the xcode one ... – David Seek Oct 28 '16 at 18:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .