3

Just upgraded to macOS 10.12.1 Sierra and the mirroring display options keeps oscillating between: "Looking for Apple TV" and "Off".

In preferences i have turned AirPlay Off. But it keeps looking for AppleTV. As recommended in an earlier discussion i tried:

sudo chmod 000 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent 

but it gave an error:

chmod: Unable to change file mode on AirPlayUIAgent: Operation not permitted

It looks like Sierra always wants to keep connecting to Apple TV - big nuisance. Any other ideas to turn this auto feature off?

  • Can you reference this "earlier discussion" by giving the source? – Brick Oct 28 '16 at 4:56
  • Possible duplicate of apple.stackexchange.com/q/255662/37413 except I don't know if the other person had some problem with it always trying to connect with something or just wanted it disabled for other reasons. – kal-al Nov 3 '16 at 21:43
  • I have this issue with High Sierra when I have bluetooth enabled. Turning bluetooth off made the Mirror Display options icon disappear from the menu bar. It is uncertain if that fixed the problem (i.e. stopped my Mac from searching for an Apple TV source) or just takes away the indicator. If Apple TV runs over bluetooth, then this is a lame fix. However, there are times where I would like to have bluetooth on, but no searching for Apple TV. So, this is not ideal. – gone Apr 18 '18 at 8:39
-2

You could just reboot your Bluetooth.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .