My updates badge shows 6 (also in the  menu), but the section in the updates tab seems to be collapsed (top separator line is thicker, like two lines) and not showing the available apps. I'm currently running macOS 10.12.1 (Mac App Store 2.2) and first noticed this problem today. The other tabs are behaving normally and this badge has changed from 5 to 6 updates today. I've tried restarting my computer, but the problem persists. Any ideas for fixing this?

enter image description here

  • 1
    I'm voting to close this question as duplicate because there was a question posted 12 minutes before this one, with the exact same issue. – tubedogg Oct 27 '16 at 23:11
  • 3
    please link to the duplicate – Stephen Thomas Oct 28 '16 at 0:20
  • Same behavior on my machine. – JW. Oct 28 '16 at 0:28
  • I'm getting the same issue. Mine was showing 6 then it became 7. – Aaron Oct 28 '16 at 0:29
  • same here. also, i know that xcode has an update, so i went to the xcode page and it wants me "to download xcode" even tho i have it on my macbook – David Seek Oct 28 '16 at 4:09

Had the same problem. Solved by going to the "Purchased" tab on the App Store, looking for software that needed to be updated (xCode, iMovie, GarageBand, Numbers, Pages, Keynote) and clicking there on "Update". I also started downloading a new App. Some 15 secs later they appeared on the "Updates" tab as well. Including a "Software Update" that contains a new iTunes, what I was looking for actually.

  • 1
    This didn't work for me – joehanna Oct 28 '16 at 2:45
  • my "purchased" is empty. going to xcode for example in the store and it wants me to download it. event tho it's on my macbook – David Seek Oct 28 '16 at 4:10
  • 1
    This worked for me, updated everything that says UPDATE in Purchased tab, then switched to Updates and boom, iTunes 12.5.2 appeared. However, the rest of the updates history were gone. – XCool Oct 28 '16 at 5:41
  • 1
    @DavidSeek try to refresh the page (Cmd + R) on "purchased tab" – DanielZanchi Oct 28 '16 at 7:44
  • This worked for me, but also after just waiting, the page eventually came back. – Zev Eisenberg Oct 28 '16 at 17:09

Same issue here. Count 6...


MAC:~ sudo softwareupdate --list
Software Update Tool
Copyright 2002-2015 Apple Inc.

Finding available software
Software Update found the following new or updated software:
   * iTunesXPatch-12.5.2
    iTunes (12.5.2), 145964K [recommended]

MAC:~ $ sudo softwareupdate --install --all
Software Update Tool
Copyright 2002-2015 Apple Inc.

Finding available software

Downloaded iTunes
Installing iTunes
Done with iTunes

After this, down to 5, but still wrong..

  • what will be the command to install only one software update, not the all? – Asad Ali Nov 3 '16 at 10:13

The App Store was showing a badge count of 4 items to be updated on my Mac (macOS 10.12.1) but nothing was displayed in the 'Update' tab.

I suspected that Pages, Numbers & Keynote apps probably had updates waiting given that their iOS versions were updated earlier today, so I located those apps on the 'Featured' page of the App Store and saw that they had an 'update' button. So I updated all three from there.

After that, I went back to the 'Update' page of the App Store and found that iTunes 12.5.2 updated was now displayed and could be updated.

Badge count is now zero!

  • 1
    Followed this. After updating only one app (Numbers), the Updates tab showed all the remaining apps that needed updating. – joehanna Oct 28 '16 at 2:46
  • Updates indicated seven, showing none of them. After updating Pages, Numbers, and Keynote under Purchased, then the other four showed up under Updates. They were Xcode, GarageBand, iMovie, and iTunes. – Mark Adler Oct 28 '16 at 4:21
  • It was the numbers update that did it for me, once that was done, the others appeared, but the history was cleared. – Niall Oct 28 '16 at 8:59

This happened to me today. When my Mac eventually prompted me to install updates with the reminder notification, I was able to install the 6 updates. They included Garage Band and other Apple apps along with XCode. Then, later I got an iTunes update. But still all my app update history is gone and that tab is blank.

  • 2
    My history looks blank now too. Sierra 10.12.1 update seems to have a significant update bug in it. – Br.Bill Oct 28 '16 at 4:42
  • App Store uses a WebView, so it could just be that Apple have an issue on the website that handles the update page – jdnoon Oct 28 '16 at 11:20

Not the answer you're looking for? Browse other questions tagged .