1

I'm trying to use some shortcuts in Sublime Text 3 (on OS X 10.9.5), but every time I press command-control-up or command-control-down, I get a Space Above or Space Below message. It doesn't do anything, and I don't really care about spaces, and I want to disable this so that OS X stops hijacking the keyboard sequence that I'm trying to use.

As far as I can tell, I don't use spaces at all, and would be totally cool with disabling that completely if that's an option (unless I am using it behind the scenes without realizing it).

1

You should be able to disable them through Prefs > Keyboard > Shortcuts > Mission Control, and then uncheck "Move left a space" and "Move right a space".

Those aren't actually the default shortcuts to switch spaces though, and there shouldn't be any "message" when using the shortcuts, so it sounds like it might be another app doing the hijacking, not OS X itself. Are you using any window managers or similar that might be implementing this? BetterTouchTool, Keyboard Maestro, SizeUp or whatever. Have a look through your login items and see if it still occurs with no background apps running.

  • you were totally right - it's size up that was doing this! ok that explains why there weren't any results for my google searches about this :P thanks @tolgraven! – thisissami Oct 27 '16 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .