My dock tells me I have 8 available updates:

app store

I also got the notification asking to install updates. However, when I open App Store, I only see recently installed updates (with no updates to apps or software visible):

updates installed

If the updates are real, how do I update, and if not, how do I get rid of the bubble?

Edit (more information):

$ defaults read com.apple.appstore
    "NSWindow Frame Preferences" = "0 116 1277 661 0 0 1280 777 ";
    "NSWindow Frame window_prefs" = "20 51 1240 726 0 0 1280 777 ";
    SeenOSUpdates =     (
    Storefront = "143441-1,13 ab:WJ6jMoo1";
    appStoreBadgeCount = 7;
    "com.apple.appstore.WebKit2DeveloperExtrasEnabled" = 1;
    "com.apple.appstore.WebKit2ShowsToolTipOverTruncatedText" = 1;
    "com.apple.appstore.WebKit2SuppressesIncrementalRendering" = 1;
    "com.apple.appstore.WebKit2UserInterfaceDirectionPolicy" = 1;
    "primary.WebKit2DeveloperExtrasEnabled" = 1;
    "primary.WebKit2ShowsToolTipOverTruncatedText" = 1;
    "primary.WebKit2SuppressesIncrementalRendering" = 1;
  • Thats odd. My output has an ` availableUpdates = (); ` block. Only thing I can think of at this moment is create a new user and see if it still shows the updates? Other than that, a reinstall of Sierra if you've tried everything I've provided. But I'd delete the apps and reinstall first.
    – Jahhein
    Commented Oct 28, 2016 at 1:21
  • Created a dummy user and switched to that account, still showed 7 updates even though I did not sign into iCloud.
    – AAM111
    Commented Oct 28, 2016 at 1:26
  • I believe this is because the apps themselves are linked to an iCloud ID and you didn't need to actually log in because of that. This is to ensure the apps are legitimate, what iCloud account it was downloaded with, etc. Has to do with receipt files on your system.
    – Jahhein
    Commented Oct 28, 2016 at 1:29
  • So what do I do?
    – AAM111
    Commented Oct 28, 2016 at 1:39
  • 1
    The accepted answer in this question (which has been closed as a duplicate of this one) is the solution, and much simpler: apple.stackexchange.com/questions/258979/… Commented Oct 28, 2016 at 10:36

7 Answers 7


The App Store was having problems since yesterday afternoon.
It was not your fault, the problem was on their end.
But it is back now.

  • I also believe this is a server overload issue where the update catalog being served to the Mac clients causes wrong calculations. Nothing has changed on dozens of Macs we manage that had this issue other than time passing and this issue has cleared up across the board now.
    – bmike
    Commented Oct 28, 2016 at 13:45

I would try the following command in the terminal to download and install updates available for your mac. All commands below require administrator privileges and will prompt for your password which is NOT relayed to the screen. You will not see the caret move at all as you type it in or be replaced by "*" per character of your password. This is normal.

sudo softwareupdate -ia

This downloads and installs all available updates.

If perhaps you have configured a different App Store catalog (Usually done in businesses) you can run the following command first and then the above command. You can run it anyway to restore the catalog to defaults if you're not sure.

Reset default catalog for App Store:

sudo softwareupdate --clear-catalog

For business Macs that need to restore the catalog back to the business's you can do that with the following command:

sudo softwareupdate --set-catalog <URL GOES HERE WITHOUT BRACKETS>

The first command I stated should download and install all updates but sometimes bugs happen and things don't work. Another attempt to solve the issue could be the following command first.

Reset all ignored updates:

sudo softwareupdate --reset-ignored -ai

More edits! Lets try seeing what the app store thinks is needing an update with this command:

defaults read com.apple.appstore 

Last possible option I can think off is to write that no updates are available. If there are updates available this won't fix that, but it'll change the updates available number.

defaults write com.apple.appstore appStoreBadgeCount 0 

This may change the badge count.

Sometimes nothing works, and a reinstall may be the best option. Steps below.

Don't forget to backup your data!

  1. Download MacOS Sierra from the app store.
  2. Reinstall by opening it and running it


  1. Wipe a USB Drive or Partition it with 6GB minimum named Untitled
  2. Run the following command after downloading Sierra to create a bootable USB.

    sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Sierra.app

    This may take a bit of time to copy onto the USB.

  3. Now, boot into recovery mode by holding down alt/option directly after starting up your mac.

  4. Here you will be presented with the USB option (Don't forget to plug keep it plugged in or it won't show up) NOTE If a firmware Password was set, you will be required to put it in to boot it up and choose a disk to boot from!
  5. Booting up to the USB will be like recovery mode and you can wipe your Mac's HD/SSD and reinstall a fresh clean copy of OS Sierra.

Don't forget to backup your data!

Reinstalling via alt/option + command + r into the internet recovery (If available on your mac model) will revert and download and old OS that it came with out of Apple's Facility then to Sierra, so a bootable USB is a good option and you can keep it there for another use.

  • I only found 1 update with softwareupdate -l
    – AAM111
    Commented Oct 28, 2016 at 0:23
  • More than likely it was the newest iTunes update just released a few hours ago. Which in that case didn't solve your problem. I'm getting an SSL error for those photos preventing me from seeing them. Today was the expiration date on the certificate. Sorry about that.
    – Jahhein
    Commented Oct 28, 2016 at 0:37
  • I noticed that you said -l for list. Can you do a sudo softwareupdate --reset-ignored and then -ia which installs all.
    – Jahhein
    Commented Oct 28, 2016 at 0:38
  • 1
    No problem @OldBunny2800 however I'm sorry we couldn't solve it without a reinstall. I tried everything I could think of. Thank you for still accepting the answer. :)
    – Jahhein
    Commented Oct 28, 2016 at 2:34
  • 2
    Why wouldn't I? You've been helping me, a complete stranger, for no compensation for the past two hours straight. I would give you a bounty if I could! :)
    – AAM111
    Commented Oct 28, 2016 at 2:36

Updating from the purchased tab on the app store fixed the problem.

  • This fixed the problem for me - there were a number of items showing up with "update" beside them in the Purchased tab, but not showing up in the Updates tab. Commented Oct 28, 2016 at 10:33
  • at my appstore it says: you have not purchased any apps
    – David Seek
    Commented Oct 28, 2016 at 11:59

Go to System Preferences and search for Updates, activate Auto Update and the Updates will be downloaded -> automatically.

enter image description here

I still don't see the available updates, but they have been updated and installed in the background. And since I guess, that this is just a temporary bug (it can't be coincidence, that thousands of users have the same issue simultaneously...) , this should work as work around.


The simplest solution I found was to go into cache and delete two folders called com.apple.appstore

  1. Go to Finder and press + Shift + G;
  2. Locate ~/Library/Caches/com.apple.appstore and delete com.apple.appstore which are cache files;
  3. Then press again those commands and go /private/var/folders, open each folder and each subfolder (probably C subfolder) until you find com.apple.appstore and delete this folder;
  4. Restart your Mac.

original answer found at: How to fix / Reset App Store app on Mac OSX - El Capitan


I've found that, when that happens, going to the "Purchases" tab will usually reveal that you've been logged out of the store somehow, and it will tell you you need to login again. Once you've done that, you'll be able to download updates.


Sign Out and Sign in again, and then Check for Unfinished Download solve the issue for me

Sign Out:

In the app store menu, click Store -> Sign Out

Sign In:

In the app store menu, click Store -> Sign In

Check for unfinished download:

In the app store menu, click Store -> Check for Unfinished Download

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .