0

In iCal, I add an event. I then set alert to alert, at the time of the event, Message with Sound, Basso.

Before upgrading to Mac OS Sierra, at the time of the event, I would get a pop-up banner in the Notifications area. (The banner would pop-up even if the Notifications panel was closed).

Now nothing happens. If I click on the Notifications panel, it's listed in the side bar, but it doesn't pop-up.

In System Preferences > Notifications, I have iCal set to Alerts. I've also made sure that Do not disturb is disabled.

How can I bring the pop-up banner back?

  • Still works the same for me, definitely not expected behavior. Are your other notifications working? – tolgraven Oct 28 '16 at 0:50
  • @tolgraven I have Carbon Copy Cloner installed and the alert pop-up works for that. – big_smile Oct 28 '16 at 9:54
0

I'm seeing this problem too, though it's inconsistent and only impacts my iMac. My MacBook Pro always gets all my calendar alerts, and both are linked to the same Exchange and iCloud calendars. I have tried fully re-installing Sierra on the iMac, which helped for about a week. Sometimes the missed notifications will trigger later (15 minutes to an hour later), but sometimes they'll never trigger.

There is a temporary fix I found:

  1. Open System Preferences -> Internet Accounts
  2. Select any account that has a calendar
  3. Uncheck that calendar, then immediately re-check it

All of your pending or missed alerts will trigger at once! They'll keep working for another day or so. I'm in the process of reporting the bug to Apple at bugreport.apple.com now.

  • 1
    This didn't fix it for me. – John Smith Apr 28 '18 at 4:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .