0

Spotlight has ghost entries for an USB disk that I cannot get rid of. It links to a bootable usb disk that is not currently connected. I have added that disk to Spotlight Privacy. Nothing I have tried unloading, reseting, deleting and reloading spotlight. Nothing.

These ghost entries do not show up when using Finder search.

Where are Spotlight caches stored other than .Spotlight-V100 ? There must be a place so that they survive cache rebuilding.

I am on 10.12.1 MBP and it is a clean install from two days. No use of migration assistant, etc. No external disk currently connected. Single partition.

enter image description here

1
0

The indexing is not finished, I would wait until it is finished before considering an error.

If the indexing is still going on 2 days after the clean install, you either have a big drive with a lot of files or it's hung on something. That usually happens with wrong permissions on some files and in worse cases because of I/O errors of the drive.

In order to check that you should take the following steps:

First: run the Disc Utility found in /Applications/Utilities/ to check your drive and repair permissions. Details for usage can be found on the Apple Support Pages found here

Next: I strongly suggest you rebuild the Spotlight Index in any case. A guide to do that can be found on the Apple Support Page here (In short: Click on the Apple Icon > Privacy > add your drive, confirm, then remove it again)

Most likely your problems will be solved after these steps.

1
  • The image is for illustration purposes. I have rebuilt the index several times already, letting it go to completion. It does not resolve the issue. The pointer for this ghost record stubbornly remains.
    – jakethedog
    Oct 27 '16 at 11:43
0

I solved this with the help of another stackexchange question. Spotlight borked after macOS Sierra update

launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
rm -R /.Spotlight-V100
sudo touch /.metadata-never-index
launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

reboot

sudo rm /.metadata-never-index

reboot

-1

In addition to the answer of @J.C. you can find out where the location is by pressing in Spotlight the CMD key. At bottom you see the path of the selected item. Double click on the item during hold down the CMD will open the location.

Workaround (hope this help)

Please Plug the named drive to your Mac. Open your Terminal and type line by line the following commands.

sudo mdutil -i off /Volumes/yourdrive
sudo rm -rf /Volumes/yourdrive .Spotlight*
sudo mdutil -i on /Volumes/yourdrive
sudo mdutil -E /Volumes/yourdrive

Change the entry yourdrive with the name of your drive.

How to find the name of the drive?

Type in Terminal ls -al /Volumes will show all connected drives by name. Note: If you begin to Type a command in the Terminal you can use the TAB key to complete the path.

Description of the commands above line by line:

  1. disable Spotlight on the named drive
  2. remove the .spotlight folder of the named drive
  3. enable Spotlight index on the named drive
  4. Rebuild the index of the named drive.

Please read the man documentation by Type in your Terminal man mdutil or on the Apple man Page

4
  • That is the problem. It points to /Volumes/Sierra/Applications/ but that disk is not connected.
    – jakethedog
    Oct 27 '16 at 14:00
  • Have you the disk still available? Connect It to your Mac and add the drive to System settings -> Spotlight -> Privacy to move it out of the index.
    – dante12
    Oct 27 '16 at 16:22
  • First thing I tried. Even in the privacy tab, it still shows up in the Spotlight window.
    – jakethedog
    Oct 27 '16 at 16:38
  • Add workaround hope this helps.
    – dante12
    Oct 27 '16 at 17:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .