4

After upgrading to 10.12.1 my Mac no longer locks after display sleep. Before the update, a login prompt always appeared. This is either using:

  1. The keyboard (⌘ ⌥ power)
  2. Timing out (set for 10min)
  3. Closing the clam shell.
  • So far two coworkers have had the same issue. One of them didn't notice the issue because he uses a screensaver which still honored his existing locking preferences. – nic Oct 26 '16 at 18:02
4

So I figured it out a solution as soon as I could ask.

I toggled the Require Password settings to "Immediately" then back to my previous "5 seconds" and now all seems to be working properly.

Changing required password time.

This required my password each time but well worth the re-enabled security. You may even be able to just uncheck then recheck the Required box. I can't test this because my issue is fixed.

  • Just curious, what app did you use to make the .gif image in your answer? – user3439894 Oct 26 '16 at 16:32
  • licecap – nic Oct 26 '16 at 16:36
  • My solution fixed the above mentioned issue for two coworkers. – nic Oct 26 '16 at 18:03
  • 1
    This worked for me as well. Was curious if there is a way to do this via the command line? – user387049 Oct 28 '16 at 2:07
  • 1
    This doesn't seem to work for 10.13.3. Use the new command ^⌘Q – cottsak Jan 29 '18 at 2:44
0

You might want to check your settings under System Preference-General. There's a setting there for requiring password after sleep or after screen saver begins, might have changed? Hope it'll work for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .