1

I am typing this question on my mac using my home WiFi network. The internet connection is fine.

My iPhone 5 running iOS 10.0.2, on the other hand, tries ad infinitum to connect to the same network, but displays a "No Internet Connection" in orange text under the network.

I've never had this problem before.

I've tried turning the phone on and off, stopping/starting WiFi, going into and out of airplane mode, but the phone persists. When it tries to connect to the WiFi at my job, it does not display "No Internet Connection", but it also tries ad infinitum to connect without success.

What is causing this problem, and how can I fix it?

Update

I wrote this question quite a while ago. I still do not know what the issue was, and unfortunately I do not remember what fixed it, and I think it may have fixed itself in a few days. If I had to guess, I would expect the fix to involve resetting network settings and restarting BOTH the phone and the modem/router (unplug first, wait 20–30 seconds, then plug back in). I would also tell the phone to check for software updates, and repeat if it installed anything. I think it MAY have been due to either a bug in a software update (which the developers quickly would have fixed), or my router/modem was having issues.

I’m really sorry I don’t remember anything more helpful. I hope that this helps somebody in some way, though!

If anyone finds an answer to this, post it!

  • Have you tried Reset Network Settings yet? If not, try that first for all similar issues. – fsb Oct 26 '16 at 15:14
  • Is the phone on your router's permitted MAC address list? – Wayfaring Stranger Oct 26 '16 at 16:07
  • Update: I'm at my job now. Resetting network settings allowed it to connect to WiFi here. I'll try it again when I get home. @WayfaringStranger: I've always been able to connect at home in the past, and have not recently changed any of the router's settings, so I have no reason to suspect that. (I'll check it out anyway if it still doesn't work tonight.) – jvriesem Oct 26 '16 at 18:33
  • Restart the router, perhaps its not giving any DHCP adress to the iPhone, then you would end up in your situation. – Niklas Oct 27 '16 at 11:34
  • @jvriesem According to this post on the apple support page your guesses may have been the exact solution. Apple suggests to: restart router and phone, if this does not help, reset network settings. In my case, to restart the router seems to have solved it already. – Kim May 13 '18 at 11:13
-2

The best thing to do is to reset your network settings by going to Settings>General>Reset>Reset network settings.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Feb 24 '17 at 13:58
  • This was one of the first things I tried, but it doesn't work! – jvriesem Feb 24 '17 at 21:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .