For the last month, my Mac has refused to go to sleep – even when commanding it to do so. The screen goes black, but the computer is still on.

I have checked Apple's support page and made sure that the Energy Saver settings are correct. I've also checked under the Energy tab in Activity Monitor and can't find anything that is Preventing Sleep. I have followed the instructions to reset the SMC and NVRAM.

In Terminal, when I do pmset -g assertions I get these results:

Assertion status system-wide:
   BackgroundTask                 1
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             1
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0

Listed by owning process:
   pid 111(hidd): [0x0000014d00090344] 00:08:52 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 
    Timeout will fire in 367 secs Action=TimeoutActionRelease
   pid 55(configd): [0x0000005f0007016b] 00:12:50 DenySystemSleep named: "InternetSharingPreferencePlugin" 
   pid 42(UserEventAgent): [0x0000006d000b0170] 00:12:36 BackgroundTask named: "com.apple.metadata.mds_stores.power" 
    Created for PID: 232. 
Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE
   id=501  level=255 0x4=USB mod=01/01/70 01:00 description=com.apple.usb.externaldevice.fd140000 owner=USB Receiver
   id=502  level=255 0x4=USB mod=01/01/70 01:00 description=com.apple.usb.externaldevice.fa120000 owner=IOUSBHostDevice
   id=503  level=255 0x4=USB mod=01/01/70 01:00 description=com.apple.usb.externaldevice.fa130000 
   id=505  level=255 0x100=MAGICWAKE mod=01/01/70 01:00 description=en0 owner=en0
   id=506  level=255 0x100=MAGICWAKE mod=01/01/70 01:00 description=en1 owner=en1
   id=507  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice
   id=508  level=255 0x8=BT-HID mod=01/01/70 01:00 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleBluetoothHIDKeyboard
Idle sleep preventers: IODisplayWrangler

PreventSystemSleep is active 1 for some reason.

Misc. info:

  • I had the old Caffeine app installed and made sure it wasn't active and then uninstalled the application. I'm not sure how to check if the system is "caffeinated", but I don't think caffeinate is stuck.
  • I've tried shutting down my other network devices while troubleshooting and don't believe that there is some network service causing the problem.

Is there a way to check what's keeping PreventSystemSleep active? Is there a way to disable it?

  • Why not reset SMC and NVRAM? Simple but often effective procedure...
    – n1000
    Oct 29, 2016 at 12:08
  • @n1000 I have now reset SMC and NVMRAM. Unfortunately, I still get the same results with PreventSystemSleep 1.
    – P A N
    Oct 29, 2016 at 12:56
  • 1
    @Winterflags - I need more coffee....
    – Allan
    Oct 29, 2016 at 13:10

2 Answers 2


From your sleep assertions, it appears you have Internet Sharing enabled. Try disabling it via System PreferencesSharingInternet Sharing.

  • 2
    Disabling Internet Sharing solved the issue. Which is silly because the only connection that was enabled is Thunderbolt Bridge and there's not even another computer attached to it...
    – P A N
    Oct 29, 2016 at 13:36
  • 2
    FYI See this question for ways to allow the Mac to sleep while Internet Sharing is enabled.
    – P A N
    Oct 29, 2016 at 13:44

In some cases, an unprinted document in offline printer could cause issues like this.

To try to solve this problem, go to System Preferences → Printers & Scanners and delete offline printers.

  • Thanks for the suggestion – I removed offline printers but it didn't help with my particular issue (also after reboot).
    – P A N
    Oct 26, 2016 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .