Sometimes the most simple things in this software are not obvious. I get a "Share Successful" message but have no idea where it is on my HD.

  • Have you tried searching for the file name in finder or spotlight?
    – NoahL
    Commented Oct 26, 2016 at 20:03
  • 1
    Yeah but forgot the name and cant re-export it to see the name so Commented Oct 26, 2016 at 20:15
  • Try going to "all my files" and looking for only movie files. You should be able to see it somewhere there (note that I'm pretty sure the file will have a .m4v extension
    – NoahL
    Commented Oct 26, 2016 at 20:23
  • 1
    What would you do in Windows?
    – grg
    Commented Nov 29, 2016 at 13:42
  • 1
    I had the same problem, and the spotlight found a file under ~/Music/iTunes/iTunes Music/Home Videos/Untitled Project (1280 x 720).m4v. That's probably a good place to look. Commented Jun 27, 2017 at 16:37

8 Answers 8


When you set up your export settings and clicked ‘Next…’, a standard save sheet appears prompting you for a location to save the file. Wherever you selected as a save location will be wherever the file is.

Once exporting is complete, the notification has a Show button which reveals the location in Finder.

If you forgot the location and missed the notification, you can still reveal the location.

  1. Select the project in the Library viewer under the event where it is located.
  2. Show the Share Inspector using the button on the inspector toolbar.
  3. Click the reveal arrow next to the shared media, then select Reveal in Finder.

  • In my case there's no save destination popup when I choose anything else than exporting master file (e.g. saving to Apple devices). What's more there's no reveal arrow as well as there's no "Exported Files" label but only "Published to iTunes Library" one. So it took me over two hours to export my video and it's supposedly "Published to iTunes" but I'm not sure what does it mean as it is definitely not on any of my HDDs and not in any iTunes-related directories. I guess I will just stick to master file export, not sure what's the point of exporting for Apple devices to be honest.
    – Bart Karp
    Commented Dec 28, 2018 at 12:10
  • @Bart In Export Settings, make sure you have it set to Open With: Do Nothing or QuickTime Player, not Add to iTunes. You've mentioned it says Published to iTunes Library, so it's added it to iTunes because of this setting. Change the setting back to default. screenshot
    – grg
    Commented Dec 28, 2018 at 12:48

When you do this you need to have 'do nothing' selected in the 'when done' box in order to get the save dialogue. Otherwise the file will go into ~/Music/iTunes/iTunes\ Music/Home\ Videos/ (yes this just confused me as well!)


The problem with disappeared exported files is that they go to the library by default AND do not assume the filename you have assigned in the export menu (hence a finder search cannot locate them but they are only visible by browsing within iTunes)


  1. click on File - Library Properties
  2. Click on Storage locations, modify settings
  3. Change the storage location for MEDIA (first item) from the "Library" default to a folder of your choice

Now, every time you export (render) to Apple devices etc, a dialogue will pop up and ask you to input a file name and storage location on your hard drive


I clicked share to 1080 Apple device. On the next pane it asks where you would like to share - such as library. Just click the box that says do nothing. It will then ask you where you want it put. It also gives the show option. Phew Whee!


Clare Herriot, thank you!! I, too, was having problems finding my shared video. It was not showing up under Home Videos in iTunes, nor was I getting an option as to where to share it. These steps do work!

  1. Click to Share to Apple Devices 1080p
  2. When next pane ask where you would like to say, click the box that says 'do nothing.'
  3. Then save it where you can find it (desktop?)
  4. Manually drag it where you want it after you've found it on your desktop.

I had this same issue. Confusingly, Final Cut puts this in your "Music" folder in your home directory. The full path for me (on Mojave with Final Cut 10.4.6) is:

/Music/iTunes/iTunes Media/Home Videos


I had to search my User dir using

sudo find ~ -type f -iname "*.m4v"

To find it in

/Users/myname/Movies/Untitled 1.fcpbundle/4-4-21/Shared Items/FIIIK5GZTCS4WH4OVoZnFA/Untitled Project (1920 x 1080).m4v
  • Could you maybe tell me what is meant by "-type f"?
    – BabyBoy
    Commented Apr 5, 2021 at 9:29
  • 1
    @DarwinOSX f = Files, d = Directories
    – Black
    Commented Apr 6, 2021 at 10:46

made an acct just to add that @Black’s solution to search the userdir for .m4v files is chef’s kiss and could also be achieved in finder by locating the fcp bundle > right click > show package contents > {event name} > shared items > then one of those should be the enclosing folder.

nearly exported the file again (not to iTunes Library this time!) until lone behold, there it was hiding in a fcp bundle’s package contents, otherwise unsearchable.

  • was able to just drag it out of there into folder of choice - no need to re-export!
    – shuck
    Commented Feb 8, 2023 at 8:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .