0

I have an MBP mid-2010, which had Sierra 10.12 running. I updated to 10.12.1 and now the MBP gets stuck booting at the screen with the Apple logo with the progress bar at 100%.

I have already tried recovery mode with first aid disk repair, but the MBP gets stuck booting afterwards as well.

What can I do to fix this?

  • Same here. Did you solve it finally? – Rod May 6 '17 at 12:27
  • Yes, see my answer. – barq May 6 '17 at 12:52
1

my MBP is a Mid-2012 Retina, and I have had this issue with both the HP Printer Update 5.0 and 5.1. I successfully ignored the update for a while, but tried today and ended up with the same problem. Here's a step-by-step fix that helped me get back on the road:

The Fix (if this sounds scary, don't do it - find someone who is comfortable with this process to help you):

  1. Hold the power button until your machine shuts off.
  2. Hold the 'command' and 'R' keys simultaneously, then start your machine. Wait for the chimes before you let go.
  3. You will boot into the recovery partition.
  4. Open the 'terminal' application (hint: it's in a menu)
  5. cd /Volumes/'your volume name here'/Library/Extensions (to figure out your volume name, type 'cd /Volumes', then type 'ls' to see the list of available volumes. The one you want to use is the one you normally boot into.
  6. type 'ls - l' when you are in the Extensions directory of your boot Volume, and confirm that you see the directory 'hp_io_enabler.kext'
  7. type 'rm -rf hp_io_enabler.kext' this will recursively delete the directory and all contents. the f means 'force'.
  8. if you like, type 'ls -l' to confirm that the 'lil guy is gone.
  9. quit the Terminal and reboot your machine to the normal Startup.
  10. get on with your life!

To hide specific updates in Sierra, right-click (Command click) on the specific update, and select the convenient 'Hide Update' that appears. How easy is that?

0

The problem was a kernel extension that prevented the boot. In my case it was hpioenabler. After removing it I was able to boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .