0

I have successfully installed Snow Leopard in a VirtualBox on my Macbook Pro Retina Early 2013 (running OS X Mavericks).

While I can start the virtualized Snow Leopard in Oracle's Virtualbox or Parallels, I have no luck starting any Rosetta Application from within Snow Leopard. This happens even after a fresh install of Snow Leopard before any updates. All Rosetta applications fail to start or even to be install.

Anyone know a configuration which allows using Rosetta in a virtualized Snow Leopard Environment?

The software versions I am using:

  • Virtualbox Versions: 4.1, 5.0, 5.1
  • Parallels Version: 8
9
  • Is the Mac OS X Snow Leopard the typical Desktop version or is it the Server version? Oct 25, 2016 at 21:31
  • @klanomath, I have looked at that thread, however, there is nothing specific for Rosetta mentioned therein. I mean they do not even confirm that a Rosetta application was successfully started. Nevertheless, thanks for you attention!
    – elcojon
    Oct 25, 2016 at 22:40
  • @klanomath, I downloaded a trial version of Parallels 11 and unfortunately it did not work either. : ( I guess it must be related to my hardware. Maybe the Macbook Pro is the problem.
    – elcojon
    Oct 26, 2016 at 20:20
  • @klanomath, I also have an Intel Core i7, my VM has 4096GB RAM. I am trying with fewer memory now.
    – elcojon
    Oct 26, 2016 at 20:23
  • 1
    @klanomath, finally I got it working after are reinstall. It seems that my originally installation, which was based on Virtual Box, was performed for 32-Bits. When installing with a 64-bit OS target, all worked.
    – elcojon
    Nov 5, 2016 at 16:05

1 Answer 1

0

it turned out that the type of the hard disk I initially chose for installing Snow Leopard on matters. So, when creating the virtual hard disk drive in VirtualBox, selecting a "hdd" Parallels type file, was the key. I tried with VDI, and VMDK (VMware) but all installations with these lead to a sucessful install of Snow Leopard, but a non-functioning Rosetta.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .