1

I edited ftp.plist by using sudo nano in terminal, and I saved by control + O but after reboot, it changed again. How can I save the file?

3
  • We are talking about /System/Library/LaunchDaemons/ftp.plist I assume. Did you verify whether your changes were written to the file after leaving nano?
    – nohillside
    Sep 24, 2011 at 6:20
  • Do you not want the file to be modified once you edit it?
    – l'L'l
    Sep 24, 2011 at 6:47
  • It was written well. Because when I quit terminal and open the file again, it was changed. But after rebooting, it changed like before it is edited.
    – Stan Pak
    Sep 24, 2011 at 7:38

1 Answer 1

0

In Finder navigate to /System/Library/LaunchDaemons/ftp.plist

  1. File > Get info Command + i
  2. Tick the "Locked" box

The file should not change now when you reboot.

Locked

2
  • I cannot see the file in the directory like this. imgur.com/CsgPm So I edited the file using Terminal. Is there any option for see all files?
    – Stan Pak
    Sep 25, 2011 at 3:11
  • I solved this problem by changing built-in ftp server's port to 9221 in etc/services file.
    – Stan Pak
    Sep 25, 2011 at 3:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .