0

Have an older large environment running FileMaker Pro 10, on OSX 10.7. It's got:

java version "1.6.0_65"

Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)

Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

The problem is that within Filemaker Server, the database Admin Console is a Java applet and ONLY runs in legacy versions, and only runs on OSX Server 10.5-10.7.. Due to a 1000 seat license ($$$$), the client won't upgrade. So we're re-installing on a 10.7 server.

the issue is that when initializing FMP10, you have to have the Console Admin, and it won't fire up withoutthe correct flavor of Java happy...

Apple has offered a version of Java that's supposedly fixing this, (java for OSX 2014-001), but it's not fixing the issue.

The symptom is that whenever I attempt to fire up the applet, i get the following

Java RE warning

Any ideas why it's not seeing the RE that I've got installed? Or do I have something else set incorrectly?

When I inspect Console, it shows an error flag:

com.apple.JavaWebStart: No Java Runtime present, requesting install.

However, if I hit terminal (java - version), it shows:

java version "1.6.0_65"

Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)

Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Why isn't it seeing/using the RE that I've got installed?

NOTE: This is a legacy issue, please skip and save yourself a headache if you intend to recommend a newer version of Java or Filemaker Pro. This isn't happenning.. It worked fine until this server HDD decided to die, and as they have a half-dozen backup units, they're not interested in dropping the financial equivalent of a midsize car into software...

1

Have you tried with the newest java from Apple: https://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US ??

And then re-enable the JRE plugin and Java Web Start as described here: https://support.apple.com/en-us/HT202643

  • The latest Java is incompatible.. Per Filemaker it has to be Java 6 or earlier... can't be 7 or 8..... – frank ankersly Oct 24 '16 at 23:58
  • Apple's Java is only v6 - Oracle is v7 and newer – Rene Larsen Oct 24 '16 at 23:59
  • yes, have 're-enabled' the JRE and the Java Web Start as shown.. It's still NOT firing up the applet.. I need Java 6 or lower... Filemaker pro won't use 7.... – frank ankersly Oct 25 '16 at 0:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .