So, there's quite a few other “Boot Camp Assistant's handling of the ‘Windows support software’ is terrible” questions; but as far as I can tell, none of them directly relate to my problem:

On a machine on which Boot Camp Assistant doesn't give the option to use external install media¹, I get stuck at the “Saving Windows support software …” step, when the progress-bar is at 100%:

Screenshot of Boot Camp stuck http://ell.io/i1l8hv+

I've left it sitting at that screen, this time around, for around 24 hours. I do have a rather large disk (2TB OWC Aura SSD), so I decided to give it some time … but it's pretty clear at this point that nothing is happening. (I'm also afraid to stop it; because last time I gave up on it, it took a solid hour to ‘remove created partitions.’ Took nearly as long to un-do, as I'd given it to do. :P)

To be clear, the download phase completed; it's stuck at the ‘Saving’ phase. Unlike old-school Boot Camp, I can't just uncheck the option and download the drivers manually; it forces me to go through this step.

So, tl;dr: Is there any way to skip the ‘downloading and saving drivers’ steps, or use pre-existing install media, or otherwise get Boot Camp working on a MacPro6,1, or "2013 Mac Pro"?

Mac-side: macOS Sierra 10.12
Windows-side: Windows 10 Pro 10.0.14393

  1. Older Boot Camp, and current Boot Camp on some machines, gives you a list of checkboxes to decide what you want it to do. Unfortunately, current Boot Camp on the 2013 Mac Pro does not do this.

“If the Select Tasks step doesn’t appear, you don’t need a USB flash drive or hard drive to install Windows. Follow the instructions in Install Windows on your Mac without using a USB hard drive or flash drive.”

  1. I've also taken some additional information — current disk partitions, process-sample for Boot Camp Assistant (spoiler: it's sitting around doing nothing.), and etc: https://gist.github.com/ELLIOTTCABLE/5f0c13cbe38a7ab952b82ec11ae4ed2e
  • 1
    One of the menus has an option to download the drivers, so you don't have to undo everything. Commented Oct 24, 2016 at 20:08
  • Note, as mentioned, this is the version / approach that doesn't give you an opportunity to use pre-downloaded drivers. It downloads the drivers, copies them and the Windows ISO to temporary partitions, and then restarts, all in one fell-swoop: no options are presented. Commented Oct 24, 2016 at 23:01
  • Tried the action menu? Commented Oct 24, 2016 at 23:18
  • … I'm not saying the Action menu option to download them isn't there. I've already done that, for my laptop, and have them on a flash stick … on some Macs, like the Mac Pro, you can't use arbitrary Windows Support Software. Yes, the menubar option is still there; but it's completely irrelevant. Commented Oct 24, 2016 at 23:20
  • It isn't arbitrary. It downloads the software specific for your Mac, if applicable. I'm not sure why it would behave differently on the pro... Commented Oct 24, 2016 at 23:23

3 Answers 3


I second ELLIOTTCABLEs answer. When I was stuck at that exact phase, after giving it a good thirty minutes or so at 100% bar fill, I simply ignored it and went ahead and restarted my computer and it starts on windows. I don't know why this happens or why this works but it did... give it a shot


Open the disc you are saving the drivers to, notice the bootcamp folder. Inspect the contents and whilst refreshing see if the size of the most recent .exe is increasing or static. if increasing, let it wait and if static and has been for a little while, then it has completed or indeed stalled.


It's not much of an answer, so apologies if you come across via Google - but after sitting incomplete for something like two days, power to the workstation got cut; and it rebooted into Windows.

It's not precisely what worked for me, but if this happens to you, perhaps try killing the Boot Camp Assistant, so it doesn't have an opportunity to undo its work? Despite the ignoble end to its efforts, the resulting Windows indeed opened up to the installer, so it seems to have worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .