4

Holding down a key on the keyboard does not cause it to repeat correctly. The key will repeat, but only after 2 seconds or so. In some cases it doesn't repeat at all. There are a few suggestions floating around in forums but none seem to correct the problem.

Settings in preferences are ignored: enter image description here

Interestingly, key repeat does seem to work in Terminal, but that's the exception. It's broken in Notes, Mail, TextEdit, etc.

Any ideas?

2

This bug was fixed by Apple in macOS 10.12.1, released a few hours after I wrote the above ...

  • We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Oct 24 '16 at 23:48
  • Your comment doesn't seem to refer to my question. My question is very detailed and specific and includes a screenshot. The answer does not need the same level of detail because the 10.12.1 macOS update demonstrated that my question was caused by a bug in 10.12.0. Apple, as you know, doesn't provide exhaustive lists of every bug they fix in point releases or any releases so what is there to link to? – demianturner Oct 28 '16 at 22:10
  • I'm still having the issue on 10.12.2. Was the bug reintroudced? – rafaelcosman Dec 21 '16 at 6:20
  • It's true that characters repeat with a maintained keypress only in Terminal, I also don't get repetition in Notes, Mail and TextEdit. However the "bug" was particularly bad in 10.12.0 where you could not hold down the delete/backspace key to delete a line of text, this now works fine. I believe key repeat was removed about a year ago in favour of a popup menu which gives you accented characters in different languages (on some characters). But repeat on the delete key should always work, which is does for me in 10.12.2. – demianturner Dec 21 '16 at 9:13
0

This worked for me on macOS 10.12.2:

http://www.howtogeek.com/267463/how-to-enable-key-repeating-in-macos/

In a nutshell, it says to:

  1. Open Terminal
  2. Enter the command: defaults write -g ApplePressAndHoldEnabled -bool false
  3. Restart

You need to restart after toggling this setting on OR off.

  • That's good to know, thanks. I actually prefer the default behaviour and use the popup with accented characters. I updated the title post to better reflect the problem, which was fixed in macOS 10.12.1 – demianturner Jan 19 '17 at 3:19
  • As an additional comment - this will change the behavior of "press-and-hold to get diacritic keys" - like the "en-yay" n key (ñ) will no longer be available by holding "n" and then pressing "1" (on my US keyboard). I spent a long time remembering the diacritics codes for some keys, so it doesn't help me. – Jon V Apr 25 '17 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .