In the last 2 days, I have found it difficult to login when I start up my mac pro retina. When I try to type in my password, I either have to retype the same letters multiple times or press the same letter key a few times before it is accepted.

I tried NVRAM reset, SMC reset - no different. I tried Apple support via chat and was instructed to set up a new test admin account - same problem remained. I rebooted in safe mode - the issue resolved. So I was told it was best to reinstall macOS Sierra in recovery mode, but the problem persisted after I reinstalled macOS Sierra.

It would probably be easiest to get a Genius Bar appointment and for an expert to look at my Mac, but I am going away for 6 weeks. Hopefully, I can get by until I return, but if anyone has any suggestions what could be the causes and what else I need to investigate to eliminate the problem, please let me know!

  • 1
    Do you only see this issue when you log in or do you notice a similar issue throughout typing on the Mac? – fsb Oct 24 '16 at 15:07
  • When you reinstall Sierra, was it Sierra only or did you restore all your "stuff" from a Time Machine backup? If the latter, try again and don't migrate your data - leave it as a clean install. There might be something that's conflicting. – Allan Oct 24 '16 at 15:10
  • I only see the issue at log-in but it types smoothly once I logged into my account. I re-installed Sierra only, not all my 'stuff' from Time Machine. – Goh Nov 16 '16 at 12:57
  • Hi, I have the exact same issue since I installed the latest El Capitan Security update :/ VileVault is enabled, but I don't want to turn it off / reinstall my OS. Any ideas? Did you fix the problem? – Florian Schneider Dec 17 '16 at 21:44
  • Hi, I am not sure what happened, but the issue suddenly disappeared after 6 weeks or so. I could not work out why, as I had not installed or deleted any new software or performed any software updates. So I did not have to contact Apple after all. Sorry not to be of any help! – Goh Dec 19 '16 at 11:28

Today I've received my Macbook from warranty due to same problem and they have replaced I/O Board. Issue has been fixed.

  • 1
    Bad USB bus or bad device connected to the bus could mess up the key input buffer. – bmike Dec 21 '17 at 14:13

Might the problem be with the FileVault on login ? Try turning it off in the settings and see if the login issue resolves. Then, maybe, try to fix permissions, on the main disk and reenable it ?

  • Actually, It resolved for me by removing the microsd card, which I use for storage. Need to investigate why is that now. – rutrack Oct 29 '16 at 11:24
  • Thanks, but FileVault is off on my Mac. I think I will wait till I return from vacation and get an appointment with Apple to see if they can figure out what is the issue. – Goh Nov 16 '16 at 13:00

You must log in to answer this question.

protected by Community Nov 6 '16 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .