3

I have the Pokémon Go app displayed on my lock screen and on this other screen. Is there any way of removing the icon from the lock screen?

5

Go to SettingsGeneralHandoff & Suggested Apps and disable Installed Apps under Suggested Apps. This removes suggested apps from both the Lock screen and app switcher — it's not possible to disable one without the other.

  • Where is the suggested app? I see the hands off but not the suggested apps – Megz Oct 23 '16 at 20:05
  • @Megz Both suggested apps and handoff appear in the same location—the bottom-left of the lock screen or at the bottom of the task switcher. In this case, Pokémon Go is appearing as a suggested app (as it mentions in the task switcher view, it's suggested due to the user's current location). – Calrion Oct 23 '16 at 22:44
2

The above option in @grgarside's reply isn't available on my iPhone - this option must have been removed in iOS 10.3.3, which is what I am running. The only option I could see was this one:

Go to Settings > General > Handoff and then turn Handoff OFF.
Worked for me on an iPhone SE running iOS 10.3.3

At first this seemed to work, but it hasn't completely stopped icons from appearing on the lock screen. However, turning off the Siri App suggestions, as mentioned by Jaime, does seem to have resolved this issue for me.

  • This turns off ALL Handoff functionality. The other answer is much more precise and it's pretty much the same. – Jaime Santa Cruz Sep 19 '17 at 15:18
  • The other option wasn't available on my phone - they must have removed it in 10.3.3. Also, the above didn't totally stop the icons appearing on the lock screen, so something else must also use that feature. Jaime - which version of iOS are you using? – Will Sep 28 '17 at 9:37
  • Will, you’re right about the option being removed from the Settings on iOS, sorry. If you add this information to your answer I can remove my downvote. However, what is shown on the screen capture is a suggested app, which is found on another preference setting. They look pretty much the same tho. – Jaime Santa Cruz Sep 28 '17 at 15:30
1

Suggested apps based on your location must be deactivated by disabling the Siri Suggested Apps widget on the Notification Center.

This guide explains how to do it:

First, swipe right on your home screen to access the widgets screen.

Scroll to the bottom of the widgets and tap “Edit”.

On the Add Widgets panel, locate Siri App Suggestions and tap the red minus.

Finally, tap “Remove”.

If app suggestions don’t immediately disappear, you may want to restart your iPhone.

This will not disable the Handoff functionality (the ability to continue doing the task where you left on our Mac), which will show an icon on the exact same spot. To disable that as well you must disable Handoff altogether.

I’m on iOS 11.0

0

None of the mentioned solutions worked for me. Turning off Siri, on the other hand solved the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .