0

I recently updated to 10.12 - Sierra- and migrated iPhoto to Photos. In the system preferences I do not see a choice to select Photo library. In the source panel I just see National Geographic/Aerial/Cosmos/Nature patterns. I would like my photos to be my screensaver. Any help?

  • 1
    Look at this answer. It's for Yosemite not Sierra but it might work. – fsb Oct 22 '16 at 23:46
  • If still no joy, check in Photos prefs/General that your Library is actually set as the System Photo Library. [The button to set it will be greyed if it already is] – Tetsujin Oct 23 '16 at 8:28
  • Try create events in Photos.app, usually appear at top in source options. – Vagner Oct 23 '16 at 19:31
1

I have just spotted an older (2012) answer at this link: http://hints.macworld.com/article.php?story=20120112094116261 However it suggests clicking and holding the "Screensaver" tab, which didn't work for me. But clicking and holding the "Source" drop-down menu button did work for me - up comes an option to use "Photos" but if you choose that, you can then choose between the "Photos" app and "iPhoto" app. This is a better solution than the one I just posted, I think.

0

Try this.

  • Decide which iPhoto library you want to use, and open a finder window with the iPhoto library icon showing.

  • Hold down the Control key and click the iPhoto library icon. You should see a drop down menu including an option "Show package contents".

  • Select the folder "Masters" or "Previews" (both seem to produce the desired effect - I suspect "Previews" has the edited images, but we'll need an expert to answer that).

  • Create an alias.

    You can do this three ways:

    • with the folder selected, click "File" in the Finder menu bar and select "Make alias", or use the shortcut "Cmd/L". Then drag the alias out of the "Package contents" window - to the desktop for example or your "Pictures" folder.
    • You can also hold down "Alt" and "Cmd" and drag the folder you want - this will create an alias as you drag, indicated by a little curvy arrow on the icon you are dragging. Right, now go to System Preferences/Desktop & Screensaver, select the "Screensaver" tab, and use the "Source" drop-down menu that appears just under the "Preview" box on the right, selecting the option "Choose folder". Use it to navigate to the alias that you have just created. This works for me under OS 10.12.1 (Sierra).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .