1

I am trying to add HP P1606DN as a USB printer. The instructions from HP say to use Apple Update via the Printers & Scanners dialog: HP Printers - Installing a Mac Printer Driver Using Apple Software Update.

However nothing shows up in that dialog.

enter image description here

So then what is the correct procedure to download/install printer drivers known /recognized by El Capitan ?

Btw here is the Printers and Scanners after tryng both (a) Apple update and (b) manually installing the HP printer software. In both cases the new printer does not appear

Update the HP printer is giving a dialog "The disk you inserted was not readable by the computer". So maybe this were a case of a problem specific to the printer.

enter image description here

But the thing is - the HP installation info directs us to use Apple Update. So feels like we were going in circles here.

  • Is this a network printer? If so, do you know its host name or IP address? – NoahL Oct 22 '16 at 20:03
  • good question - i had neglected to mention (usb) and have updated OP – javadba Oct 22 '16 at 20:20
  • From my understanding USB printers should automatically initialize when you plug them into the computer. What does the "printer and scanners" panel look like after you've plugged the printer in and turned it on? – NoahL Oct 22 '16 at 20:32
  • @NoahL The HP printer does not appear. The existing Canon printer is listed. – javadba Oct 22 '16 at 21:17
  • Had you tried downloading the update from HPs website (that you linked) and installing it manually instead of going through Apple Software Update? – NoahL Oct 22 '16 at 21:20
1

HP has its drivers readily available on its website. Just google the name of the printer.

That led me to this link. Which seems to have the driver you need.

Apple Software Update does not always have the driver you need. It has gotten so that any time I install an HP printer I just google the name for the latest driver as the CD that comes with most printers is Windows only or out of date. Also they often install a bunch of crap advertising HP supplies.

0

It appears that USB Printing for Mac from this printer simply does not work. IP printing otoh is working fine.

The printer has a button to depress for several seconds and then prints the configuration page. If that trusty rj45 were plugged in then an IP address will be showing up. OS/X has no problem whatsoever with finding the IP enabled printer.

0

Have you tried opening App Store with the printer connected? I had a similar issue that was solved by downloading HP Drivers Update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .