0

today i'm trying to use the typical 'caffeinate -t 1000' on terminal and get this output:

Gabrieles-MacBook:~ black$ caffeinate -t 1000

-bash: caffeinate: command not found

So i read the man page and i saw the path was /usr/bin/ and no binary of caffeinate there. What can i do? I tried caffeine and owly from the appstore with no results. I don't understand. I used it every day when i had mountain lion or el captain. Now i did a downgrade on macbook because el cap is too slow and now i have lion 10.7.4

Thanks, Gabriele.

  • What happens if you use the fully qualified pathname? /usr/bin/caffeinate If that works and caffeinate by itself doesn't, then you have a problem with your PATH variable. Check and see if /usr/bin is in your PATH using: echo $PATH – user3439894 Oct 21 '16 at 14:34
  • What do you get when you issue the command find / -name caffeinate? When you did the downgrade, did you wipe your drive? – Allan Oct 21 '16 at 14:41
  • Sorry guys, i enabled the notification when i get registered but it doesn't worked! @user3439894 i did /usr/bin/caffeinate -t 5454 and get: -bash: /usr/bin/caffeinate: No such file or directory – blackfromabove Oct 25 '16 at 21:09
  • @blackfromabove, Did you try the find command suggested by Allan and did it find it? – user3439894 Oct 25 '16 at 21:22
  • @Allan Yes man from the disk utility on lion fresh installation. My output is: find: /dev/fd/3: Not a directory find: /dev/fd/4: Not a directory Anyway guys just googling better found this from osxdaily: To use the caffeinate command you’ll need to be running a fairly modern version of OS X, as the feature was introduced in 10.8 Mountain Lion and persists through 10.9 Mavericks, and into 10.10 Yosemite. And googling yet better than before found this: pmset noidle That force to stay awake! Same behavior so so, in any case this works and i'll use it! Thanks to all! – blackfromabove Oct 25 '16 at 21:29
1

"To use the caffeinate command you’ll need to be running a fairly modern version of OS X, as the feature was introduced in 10.8 Mountain Lion and persists through 10.9 Mavericks, and into 10.10 Yosemite. Heads up to MacWorld for the tip." Source: http://osxdaily.com/2012/08/03/disable-sleep-mac-caffeinate-command/

Alternative to caffeinate: http://lifehacker.com/5767991/how-to-force-your-mac-to-stay-awake-indefinitely-via-the-command-line Thus work for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .