23

On macOS Sierra, I am encountering a strange behaviour of WEBLOC files. In the Open with: section of the Info window, the drop down list for choosing the default application is greyed out. It is set to Safari even though I have chosen a different default web browser in the System Preferences. I would like to change it to the browser of my choice, but it appears I am stuck with Safari.

App drop down greyed out in Info window

When I select more than one WEBLOC file at once, the drop down list stops being greyed out. But when I try selecting a different browser, I get the following error message:

You can’t change the item “Ask Different.webloc” to always open in the selected application.

The item is either locked or damaged, or in a folder you don’t have permission to modify (error code -10823).

Error message while trying to choose a different default application for WEBLOC files

Needless to say that this particular WEBLOC file is neither locked nor damaged and that I have all the required permissions for the containing folder and the file.

How can I change the default application for WEBLOC files so they open with the browser of my choice?

2
  • 3
    6 years later I still have the problem in Ventura Dec 26, 2022 at 8:12
  • Me too, any solutions? Jan 1, 2023 at 22:03

6 Answers 6

10

Please note: This solution no longer works in macOS 13 Ventura (or already before?). Please see the other answers for solutions that work (and downvote this answer).

I have found a solution:

  1. Make sure that the Finder is set to show all filename extensions (Finder Preferences → Advanced).
  2. Edit the file name by deleting the “.webloc” filename extension.
  3. Show Info: Lo and behold – the application drop down list is no longer greyed out. Application list no longer greyed out after deleting ".webloc" filename extension
  4. Select the browser of your choice and press the Change All… button.
  5. The default application for opening any WEBLOC file has been changed, whether or not it has the explicit “.webloc” filename extension.
7
  • this seems to change the default application listed in "Get Info..." but doesn't actually change the application that opens when you click on the file...
    – honi
    Dec 22, 2016 at 20:20
  • 1
    This worked for me. The icon is still showing Safari, but when I double click it opens it in Firefox. Hopefully it'll stay this way.
    – The Oddler
    Jan 5, 2017 at 13:23
  • Worked for me, too. Had a warning about changing the app for “ilht” files, ignored it. May 16, 2018 at 20:32
  • 2
    Just removing the extension didn't work for me. I had to change the extension to .txt, then I could edit the setting in GetInfo, then I removed the txt extension. The icon still shows as a text file, but it opens as expected in Chrome.
    – B B
    Mar 4, 2019 at 14:37
  • 1
    This did not work for me in Catalina - I can change the extension, or remove it, and yes that unlocks the Open With dropdown and I can change all. But when I rename the file back to .webloc, the icon changes to the @ HTTP default and double-clicking the file launches Safari. Get Info also shows Safari again as the Open With selection.
    – mcw
    Dec 9, 2022 at 15:02
5

The currently accepted answer doesn't work for me, but one way to make this work is to use the duti utility. You can install duti using homebrew or build from source.

Warning: any time you change default applications you could end up doing something that is hard to reverse, and moreso when done via the command line, so proceed only if you are comfortable.

To instruct Finder to open all webloc files in Chrome, you just need to run the following command in the Terminal:

duti -s com.google.Chrome com.apple.web-internet-location all

I haven't tested this over a long period of time, so I don't know how long the effect lasts or if this will break in the future, but it works on MacOS 13.1.

4
  • Thanks for this new answer. I never bothered to check since for me, the WEBLOC files manipulated as described in the other answer continue to open with Firefox. But now I checked with a virgin user account and the other answer indeed no longer works. Incidently, do you have a silicon Mac? And if you do, could you check whether the settings pane solution described in the other new answer works there? Also, if you feel the other new answer is too much of a rip-off of your answer, feel free to integrate it into your answer.
    – mach
    Jan 5, 2023 at 21:38
  • The current brew install is duti-1.5.4 which was tagged on 2018.04.12. Is brew install --HEAD duti with the latest "master" branch updates needed for the ARM-based macOS Ventura? Jan 6, 2023 at 4:31
  • Thanks! Works great on m1 + Ventura! Jan 20, 2023 at 5:56
  • It's not working for me with Ventura 13.5. Aug 8, 2023 at 21:40
5

I found the following solution in Roy Caratozzolo’s answers to Default browser not working in Ventura 13.1. I am reposting Roy’s solution here hoping that more people will find it useful. Also, I guess this is basically the same answer as the one by Nathan Grigg but with settings panes instead of a CLI app.

A way of setting a browser of your choice to open WEBLOC files is through a dedicated pane in the System Settings. There are at least two setting panes that will do the job:

  1. The SwiftDefaultApps settings pane:
    • Download the latest SwiftDefaultsApps ZIP file from https://github.com/Lord-Kamina/SwiftDefaultApps/releases and doubleclick on the SwiftDefaultApps.prefpane you find inside.
    • The System Settings app will prompt you that the SwiftDefaultApps settings pane needs to be installed before it can be used. Do so by clicking on the Install button. System Settings app will prompt you that the SwiftDefaultApps settings pane needs to be installed before it can be used.
    • In the SwiftDefaultApps settings pane, go to the Uniform Type Identifiers tab and scroll down to the com.apple.web-internet-location entry. Then click on the Radio Button next to Other … in the Viewer section. A file selection window will appear where you can Add the browser of your choice. “Uniform Type Identifiers” tab, com.apple.web-internet-location entry
  2. The RCDefaultApp settings pane. This works very similar to the SwiftDefaultApps settings pane. It may prove more difficult to install since it is not signed (it appears to be from the days before app signing). It works very similar to SwiftDefaultApps (SwiftDefaultApps was modeled after it). Also, RCDefaultApp may no longer work on Apple Silicon Macs.

Caveat:

  • These settings panes do not have a reset option. The settings you make will persist even when you uninstall the pane afterwards. Of course, the default application for WEBLOC files can be easily changed back to Safari, but be careful not to change too many other settings.
1
  • SwiftDefaultApps preferences panel worked OK, for me, on an M1 machine with Ventura 13.1 Jan 6, 2023 at 6:59
0

Using thamind's answer, this worked perfectly for my requirement.

The code I used for my use case was as follows:

tell application "Firefox"
    
    activate
    
    open location "https://listen.tidal.com/"
    
end tell

This allowed me to save as an Application and then drag on to the docking bar. TIDAL is not available in the App store. That being said, I have since seen that they now have an installer for MacOS on their downloads page, but I thought the above might be of use to somebody, someday.

-1

In System Preferences>General (in Catalina at least), you can change your default web browser. Whatever that is set to is the app that will open .webloc files.

3
  • This is completely incorrect. Default web browser does not affect default application for .webloc files at all. Just tested in Monterey, Big Sur, Catalina, and High Sierra. Apr 1, 2022 at 15:51
  • @Wibo It does, also Monterey here. However, I doubt the accuracy of the term "Default Application" here. To be more specific, it affect the double-click, but not the "open" command from terminal.
    – nichijou
    Nov 13, 2022 at 12:22
  • I don’t understand the downvote and negative comment. This works perfectly, and is the official way to solve this problem (in Catalina, at least).
    – Calion
    Apr 25, 2023 at 21:07
-2

Old question, still an issue to this day in OSX Mojave 10.14.5

I have found the best solution possible, although it is a couple steps just to do it.

Still useful for shortcut files you use frequently on your desktop / folders

  1. Open AppleScript Editor (Script Editor)
  2. Copy / Paste the following into the editor:

    tell application "Google Chrome"
    
    activate
    
    open location "https://www.url.com/"
    
    end tell
    
  3. Then File > Export...

  4. File Format: Application

  5. Choose a location and hit save. This will create a location.app which, when opened, will go into your Chrome browser instead of Safari! This will also work if you replace "Google Chrome" with "Firefox"

1
  • This does not generalize to working for any arbitrary .webloc file, since you need to know the contained URL.
    – mcw
    Dec 9, 2022 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .