1

Two of my USB sticks (Lexar and PNY, both 32 GB) are not getting recognized correctly by macOS Sierra. Both worked before (one formatted with NTFS, the other with FAT32); they were then used as installation media for upgrading a couple of MacBooks to macOS Sierra.

They have since been tested, getting reformatted by Linux as well as Windows 7 between tests, but the following output is always the same using diskutil list:

/dev/disk3 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: Apple_partition_scheme *32.0 GB disk3 1: Apple_partition_map 4.1 KB disk3s1 2: Apple_HFS 311.3 KB disk3s2

After plugging them into the MacBook they are still working on Windows and Linux (they were tested by writing the whole stick and verifying the data). I also deleted the partitions using fdisk in Linux.

Is there a way to repair this behavior? And if not, is there a way I can redefine how the partitions are getting assigned by macOS so that I can still manually mount them?

2

There's nothing wrong with what you are seeing. That's the partition scheme for your bootable USB. When you format it, you are not deleting the partition, just "blanking" the active partition.

Formatting a partition is not the same as deleting the partition.

To get back to a "single" partition (this is what I am assuming you want to do), issue this command in diskutil

diskutil partitionDisk /dev/disk3 1 GPT HFS+ NAME 100%

This command will permanently delete anything you have on the device. Make sure you are using the correct device identifier

Be sure to replace "NAME" with the name you want to give to the USB.

Your drive partition map will be wiped, and the HFS+ (Mac OS Extended) file system installed.

What I suspect happened in your case is that you didn't "write" the new partition scheme to the USB. This is done by issuing the "w" command. Linuxhelp has an excellent tutorial on fdisk

enter image description here

More info can be found by typing man diskutil

  • Thanks! Forgot to write that I deleted the partitions using fdisk in linux and made sure there was no partition left before writing and creating a new one. I will try to add it. – MZahn Oct 20 '16 at 14:43
  • When you created the new partition in Linux, did you remember to write it to the device? It's the "w" command in fdisk. – Allan Oct 20 '16 at 14:54
  • I did write the partition table, and the changed partition table was displayed under linux but the old setup under macOS. Solved it by filling the whole stick with zeroes, including partition table. After partitioning the zeroed stick it works on all systems again, including the MacBook. – MZahn Oct 24 '16 at 13:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .