0

I'm using an external USB keyboard (for windows, really). It's a 105-key UK layout and for some reason my ` and \ keys are switched.

This is fine, as I've obtained a keyboard layout which swaps these keys round. However, in certain applications (Office and Slack, possibly more) the layout switches back to the original British PC layout.

Also, I'm on Sierra.

How can I get my keyboard layout to persist?

1

The solution to this issue is to uncheck the "Automatically switch to a document's input source" checkbox in System Preferences -> Keyboard -> Input Sources.

If the keyboard layout is wrong then select the correct layout.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .