1

The macOS Sierra 10.12.1 public beta train keeps chugging along, but my MacBook is stuck on 10.12.1 public beta 2 (16B2333a), which I installed over two weeks ago. Apparently the current public beta is public beta 4.

I've tried going to System Preferences → App Store → Your computer is set to receive beta updates and toggling it off, then reinstalling the update enabler from beta.apple.com to turn it back on (since the preference disappears when you turn it off.)

Is there any way to convince App Store to show me updates past public beta 2?

1

I'm unsure if this solved my problem, and I'd welcome a better answer, but after asking, I

  1. Toggled beta updates off

  2. Rebooted

  3. Re-enrolled my Mac; no updates found

  4. Ran softwareupdate -l; but no updates were found

  5. Ran softwareupdate --dump-state to try to debug

  6. While I was rooting around in the dumped state and downloading and inspecting files, Public Beta 5 became available and showed up both in App Store.app and softwareupdate -l

I'm guessing that the toggling off and re-enrolling of beta updates made me eligible for the next Public Beta; though I'm not sure. I'm posting because perhaps that strategy may help someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .