I have been going in circles for two days trying to get macOS Sierra 10.12 to work with my Gigaware USB to Console (RS-232). I have tried about 10 different drivers from a google search with no luck. No matter what I do, the USB device will not show up under the TTY lines when plugged in.

I have tried uninstalling and reinstalling all of the drivers as well as changing the vendor ID to match Prolific. I have also tried csrutil disable/enable command from safe mode and managed to see it in the network settings but it still isn't recognized by any terminal program that I have tried. Zterm, Zoc, other serial programs all fail.

Additionally, a program called "Serial" from Decisive Tactics Inc. seems to work, whatever drivers they load there work but I shouldn't have to pay 30 dollars for a feature that macOS should support. Any ideas on what I can do? I'm all out of possibilities at this point and need some help. I've uploaded screenshots of what I currently have.

System Config

Network Settings

  • 1
    macOS cannot possibly contain drivers for every piece of hardware imaginable. Therefore it is up to the vendors to provide drivers. You've found drivers that work, but they cost money which you don't want to pay. As I see it, you have two options: pay for the software, or buy a cable from one of Prolific's recommended companies and then you can bug them directly if it doesn't work with their Sierra drivers.
    – tubedogg
    Commented Oct 19, 2016 at 5:06

2 Answers 2


Install libusb >1.0 (actual 1.0.20) from homebrew or MacPorts, since this one provides access for controlling data transfer to and from USB devices in UNIX/non-UNIX systems, without the need for kernel-mode drivers.

As for a free application, try CoolTerm.

I used this combination with Cortex-M4 microcontrollers.


I got it work. The fix is get an external docking station. I got one from Other world computing, a thunderbolt dock. The usb ports on the Mac mini suck and will not work with usb to serial devices.. however once I installed the dock, it has usb chipsets that are more industry standard and ALL usb2serial devices have thus far worked.

  • This is one solution, but not a true solution to what should work with the appropriate driver. Can you clarify, or better yet cite references to back up, your claim that the "ports on the Mac mini...[]...will not work with usb to serial devices"?
    – ephsmith
    Commented Nov 30, 2017 at 20:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .