4

Since upgrading to iOS 10, in certain e-mail accounts (notably an msn.com account) I cannot delete certain messages in Apple Mail. If I swipe left or open the message, and click the Trash icon, I get an error message

Unable to Move Message

The message could not be moved to the mailbox Trash.

This appears to happen only for messages that have already been deleted via a different client (e.g., Apple Mail on macOS) but that still appear in iOS. No matter how long I wait, these messages do not correctly sync with the iOS client on their own, and manually deleting them produces the error above.

All the instructions I've found online for addressing this (apparently common) issue either do not apply to iOS 10 or simply have no effect (repeating the same error). The only way to delete a message once this error occurs for it is to disable and then re-enable the offending account, or delete and re-add the account entirely. The account then correct syncs with the server and shows the already deleted messages as gone. But that only works until the error happens again.

How do I avoid "message could not be moved to the mailbox Trash" on iOS 10?

  • 1
    What happens if you go into the list of Mailboxes and pull down to refresh? What about refreshing from inside the Trash mailbox? – user11633 Oct 20 '16 at 17:00
  • @Phong: Nothing (of course). – orome Oct 20 '16 at 17:13
  • Why don't you try my fix instead of immediately down voting it? I had the same issue and what I wrote fixed it. – Chad L Feb 13 '17 at 19:53
  • @ChadL: Your answer does not address the question. – orome Feb 13 '17 at 20:04
1

Here's what I did to fix things...

(EDITED, BECAUSE PREVIOUS WAY DIDN'T WORK... EVERYTHING REAPPEARED)

Go in to settings > Mail > Accounts > (Account Name) > shut off "mail"

Force quit the mail app; force quit settings app.

Re-open mail app. It should not show any mail from that account. Force quit mail app again.

Then reopen settings, re-enable mail. Everything is re-synced. Re-open mail app.

1

The issue is caused by the way iOS names the IMAP prefix in IMAP based mailboxes. It defaults to a prefix of / but it should be INBOX. If you change the prefix it will fix the issue.

To change the prefix:

  1. On your iOS device got to Settings
  2. Passwords & Accounts
  3. Click the mailbox name
  4. Click the email address where it says Account at the top
  5. Click Advanced at the bottom
  6. Tap where it says IMAP Path Prefix
  7. Type in INBOX instead of /
  8. Done!

Instructions on how to fix IMAP 'unable to send message to trash' error

-1

This is a method I discovered when I encountered a mail glitch always displaying 1 unread email:

  1. Go to Settings > Mail > (Insert account name)
  2. Turn the slider to "Off"
  3. Restart device
  4. Turn account back on

That should fix your problem :)

  • As stated in the question even when I "disable and then re-enable the offending account, or delete and re-add the account entirely" the fix only works temporarily. – orome Oct 27 '16 at 13:08
  • I'm stumped. Sorry. Have you considered backing up and resetting your device? – CheezBiscuit Oct 28 '16 at 0:31
-1

This worked for me with an Outlook account:

  1. Settings/Mail/Accounts/[choose account]
  2. Set the option "Mail Days to Sync" to "No Limit".

This may or may not work for you, because not all mail accounts have the "Mail Days to Sync" option. Hope it helps.

-1

All previous answers did not work for me. I have gsuite / google apps paid account since that provides push mail. So none of the imap answers are very useful.

What did help was https://support.google.com/a/users/answer/138740?hl=en and specifically going to http://m.google.com/sync/settings in your iOS device' browser.

That brings up a (unknown) mobile sync settings menu that is, well, very well hidden. Tick the second checkbox Enable "Delete Email As Trash" for this device to on. Click save.

Do this per device where this email account is used.

To clear the local mail cache, go to settings / mail / your gsuite account. delete the account. When done, reboot the iOS device. After reboot, go to settings / mail / add account. Add the gsuite / google apps account by selecting EXCHANGE (see help page above). Add m.google.com as the server. User is your full email address. check your email / calendar / contacts / notes preferred settings.

And all should be fine again.

-1

This is a method I discovered when I encountered a mail glitch always displaying 1 unread email:

Go to Settings > Mail > (Insert account name) Turn the slider to "Off" Restart device Turn account back on That should fix your problem :)

Definitely worked

  • This is precisely the method described it the OP. – orome Jan 10 '18 at 20:36
-2

WARNING: Do not use these steps if the email account is configured POP in iPhone settings (Possible Data Loss).

I had this same issue this morning and since my email account (Outlook) that was having prolems was set up using IMAP settings, I was able to resolve the issue using the steps below:

  1. Ensure you're running the latest version of iOS; go to iPhone > Settings > General > Software Update to check for updates.
  2. Go to iPhone > Settings > Mail > Accounts > Select the affected account(s) > Delete Account; this will completely remove the account from your device.
  3. Force your device to restart; iPhone 7 users press and hold power + volume-down button until you see the Apple Logo, all of the other iPhone models can perform a Force Restart by pressing and holding both power + home button until the Apple Logo appears.
  4. Once the iPhone restarts, re-add the account in iPhone > Settings > Mail > Add Account.

The steps above helped me resolve the issue, after I'd already tried the steps below:

  1. Restarted iPhone.
  2. Changed the "Mail Days Days to Sync" settings in iPhone.
  3. Deactivated Mail account in settings and reactivated Mail account.
  • This was attempted and had no lasting effect, as described in the OP: "The only way to delete a message once this error occurs for it is to disable and then re-enable the offending account, or delete and re-add the account entirely. ... But that only works until the error happens again." – orome Apr 13 '17 at 20:27
  • I'm not seeing where the OP describes they've ensured they're on the most up-do-date version of iOS (currently 10.3.1). – Walt Apr 14 '17 at 13:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .