Dear respected experts,

I have a MBP Retina 2015 (Yosemite). I tried to partition my Macintosh HD ( internal 1TB SSD) disk (by splitting into half). It seemed to have split but has given me some errors about mapping or mounting...So I restarted the computer. After which, I was unable to bootup again - facing the 'stop'/'block' sign every time.

I got into Recovery Mode (cmd + R while restarting) and tried using the repair disk option. After clicking repair it keeps telling me the disk needs to be repaired. I click repair again but the same message prompting to repair again pops up. By the way, it's showing my disk as a Virtual Whole disk (500.2GB partition + 499.8GB partition). NB. I managed to erase one of the partitions (I think the 499GB one) within the Virtual Whole Disk. However, the other one cannot be erased (the option is greyed-out)

I would like to repair my disk as opposed to starting over with a brand new install. I have a pre-partition Time Machine backup on a USB drive. I tried to restore it via the recovery mode. However, it was unable to find a destination (disk) to restore it to. I am assuming the destination disk needs to be 1TB since that was the disk's size (single paritioned), although I had only used ~70GB capacity; ie the backup size on my USB drive is also 70GB.

I tried Internet Recovery Mode, as I read that I can't repair my disk via the normal recovery mode...but still to no avail. Should I perhaps bootup a Mac OS via an external USB and and try disk the utlility from there? If yes, how can I download a bootable yosemite OS onto a USB drive? (I only have one mac machine, which at the moment is not booting - have never accessed mac app store before - it's a new machine).

I am unable to boot into Single User mode (it ends up showing the stop sign plus a message about being unable to find root). I tried resetting PRAM and SCM but it didn't solve the issue.

I am worried that if I restore it would mean upgrading to El Capitan or Sierra, which (my guesses are), would render my Time Machine backup useless.

Is there any way I can repair the disk or flawlessly restore the time machine backup, which I have on a USB drive?

I accessed the terminal via recovery mode;

diskutil cs list shows the following:
CoreStorage logical volume groups (1 found)
Logical Volume Group (random digits)
name: none
status: initializing
size: 0 B (0 B)
free space: -none

Physical Volume (different random digits)  
    Disk: disk1s2  
    Status: Failed  
    Size: -none-  

diskutil list shows: 14 different /dev/disks (ie. last one is /dev/disk14).

   disk 0 is 1.3GB (Apple parition scheme)  
   disk0s1 is apple partition map (30.7KB)  
   disk0s2 Apple_HFS OS X Base System 1.3GB.  

   disk1 GUID partition scheme 1TB  
   disk1s1 EFI EFI 209.7MB  
   disk1s2 Apple Core Storage 500.2GB  
   disk1s3 Apple_Boot Recover HD 650MB  

I've triped checked that disks 2 to 14 are single partitions and are sized from 6.3MB to 524.3KB.

    gpt -r show disk0
    start        size        index          contents
        0     2600084

    gpt -r show disk1
    start        size        index          contents
        0           1                        PMBR  
        1           1                        Pri GPT header  
        2          32                        Pri GPT table
        34          6                       
        40     409600            1           GPT part - (random nos C1***3B)
    409640  976970432            2           GPT part - (random nos 53***AC)
 977380072    1269536            3           GPT part - (similar abv 42***AC)
 978649608  975560479                      
1954210087         32                        Sec GPT table
1954210119          1                        Sec GPT table
  • I managed to erase one of the partitions within the Virtual Whole Disk. However, the other one cannot be erased (the option is greyed-out). Oct 17, 2016 at 18:00
  • @klanomath, can't screenshot my mac (typing from another machine). Have updated as requested. Hope it's clear. Oct 17, 2016 at 18:32
  • Any important data on the disk? Or with other words: do you want to recover an old volume? Or do you have an up-to-date & complete Time Machine backup?
    – klanomath
    Oct 17, 2016 at 18:44
  • I have a time-machine backup and may consider restoring...right now don't want to try it - if it doesn't work then don't have data or chance to repair disk...thanks for editing the code (still getting the hang of the formatting) Oct 17, 2016 at 19:01
  • A major CoreStorage structure is completely corrupted. This can be recovered under certain circumstances but it's complicated to explain.
    – klanomath
    Oct 17, 2016 at 19:08

1 Answer 1


You probably repartitioned the main volume the wrong way. At least your CoreStorage Logical Volume Group got corrupted either by partitioning or by "repairing".

The ultimate method to reset the drive is to completely destroy the GUID partition table of the main internal disk. This will render all data on the disk useless and you need an up-to-date backup to restore your old volume.

To destroy the GUID of your internal physical disk you have to boot to an external boot volume. This may be a OS X installer thumb drive or Internet Recovery Mode (which net-boots to a recovery image provided by Apple over the network). You mustn't boot to Recovery Mode which loads a basic system in a mounted but compressed recovery image in your recovery partition diskXs3).

  • Detach any external disks - especially your Time Machine backup drive
  • Boot to Internet Recovery Mode
  • Open Terminal in the menubar Utilities -> Terminal
  • Get an overview (especially the gpt command is important!):

    diskutil list
    gpt -r show disk0
    gpt -r show disk1

    Check which of both disks is your internal disk. Usually the internal disk is disk0 and the recovery volume is disk1 if you have only one disk in your Mac. In rare cases disk1 is your internal disk and disk0 is the recovery volume. The recovery disk has ~ 2600000 blocks (or ~1.3 GB). Even the smallest SSD is much larger. Below I assume your internal disk has the disk identifier disk0 - so use disk1 (or disk2, disk3) instead of disk0 in the commands if you find an other disk identifier for your internal physical disk.

  • Unmount disk0:

    diskutil umountDisk /dev/disk0
  • Delete the GUID:

    gpt destroy disk0

    If this doesn't help, then the hard way:

    dd if=/dev/zero of=/dev/disk0 bs=512 count=40
  • Create a new GUID partition (this also creates a fresh pMBR):

    gpt create -f disk0
  • Enter exit and quit Terminal.
  • Open Disk Utility and partition your internal disk: one or two partitions and at least one JHFS+ volume.
  • Quit Disk Utility
  • Attach your Time Machine backup drive, open Restore Time Machine backup (or similar) from OS X Utilties and restore your backup.

This usually won't restore your Recovery HD. You have to do this either manually with Recovery Partition 4.0.4 or by reinstalling your current system with an Apple system installer (i.e. "Install OS X Yosemite" 10.10.5, which usually won't affect your data)

  • If my Time Machine backup was based on a non-partitioned disk (ie I backed up before paritioning), should I abstain from partitioning after quiting the terminal? Oct 17, 2016 at 19:20
  • @questioner56 No you don't have to. The TM backup is volume based and not disk based. But if your TM backup contains two volumes (e.g. a split main disk: System/Data) you obviously can't restore it to only one volume.
    – klanomath
    Oct 17, 2016 at 19:33
  • Sorry I'm not 100% sure what you mean. 1) are you saying that the recovery disk should be 1.3GB or should be >1.3GB? 2) by recovery disk do you mean the disk that contains volume: disk1s3 Apple_Boot Recover HD 650MB? 3) In my case is disk0 is the recovery and disk1 is the internal? Oct 18, 2016 at 18:13
  • really sorry but how can I determine which disk is internal if you can't determine it? I am in internet recovery mode. disk0 is 1.3GB and disk1 is 1TB. Doesn't that mean that disk1 is the internal disk? Oct 18, 2016 at 18:39
  • just been re-reading your comments. Is there a conclusion to which disk is the internal disk? Oct 18, 2016 at 18:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .