4

This is driving me crazy.

In 'Notes', with a note text open/active, I uncheck 'Edit->Spelling and Grammar->Check spelling while typing'. Now the red underlines disappear from words believed to be spelled incorrectly, as expected. I close 'Notes', open it again. The same note text is active, but the red underlines are back. Checking the menu item above, I see that it is now checked again.

How come this setting won't stick when closing/opening 'Notes'? If I open/display another note text, then open/display the first note text, the red underlines are not back - it is only when 'Notes' is closed that this setting seems to be forgotten.

I have tried this: https://discussions.apple.com/thread/2577594 (changing some system-wide settings, however written for a different version of OSX) ...but it doesn't help.

Possibly a similar problem (not entirely clear) on OSX Yosemite, however no solution: How to completely, utterly, disable spell-check on OS X Yosemite?

1

Quit all applications.

System Preferences > Keyboard > Text Tab. On the right side you should see "Spelling : Automatic by Language". In drop down list, choose "Set Up..." then uncheck English.

Nightmare free from those red underlines :D

Drawback: doing so will disable Spelling checking in system wide, while you may want to disable in one specific app only.

  • This is the solution suggested by the first link I gave; discussions.apple.com/thread/2577594 I have done so, that is, unchecked all languages but one, and left one I don't use checked. Didn't help. – Carl Oct 22 '16 at 22:59
  • Dude, I unchecked English Only! Uncheck all left one didn't work for me either :) – Huy.PhamNhu Oct 23 '16 at 7:54
0

Solution: Upgrade OS X. In El Capitan, this is simply a bug and there seems to be no workaround. This is fixed in OS X Sierra.

  • Well I would be delighted if that had been fixed, but I'm on 10.12.4 in freaking 2018 and this issue is still going strong. Everytime I reopen Sticky Notes, the Spell-Check is enabled. – rwenz3l Apr 17 '18 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .