My mac is kind of a mess right now so I wanted to fresh install MacOS Sierra.

I bought myself a brand new 8gb pendrive since is pre req. But I cant seem to get it properly erased, I always get this message:

If I try by terminal following this tutorial I also get this error:

The operation couldn’t be completed. (com.apple.DiskManagement error -69874.)

I also tried Using Install Disk Creator but I think the same thing happens because he probably use Diskutil commands:

So I am kinda lost here and don't know what else to do.

P.S. I went to the store and changed my pendrive for another one and the same things happen

PPS In every retry I had to go on a windows laptop to format again. And it works just fine copying files and it show on my mac until the unmounting processes begin

PPPS I noticed that the pendrive does not have a GUID_partition_scheme as the others

Is there any other way I fix this?


Try formatting the USB stick twice as HFS+ (journaled)/GPT. Then use DiskMaker X to write the image. This is a piece of software that is updated very often and usually doesn't have any bugs (at least to my knowledge), so it might work better than the app you are using now. If nothing helps, then you probably have a broken USB stick - go buy something like a SanDisk Ultra USB 3.0 (I have it and it works great).


Solved using an external HD.

Seems that if GUID_partition_scheme is not present, pendrive will not work as bootable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .