I have my SSD partitioned into two 128 GB disks. I was managing my disk space and decided to shrink one of my partitions (the one with Mavericks) because it had more free disk space, in order to transfer this space into my main drive (the one with El Capitan).

As I couldn't just transfer space from Mavericks to El Capitan I shrank my Mavericks partition, but then my total disk space was reduced. I did everything I could without success.

Macbook Pro Retina Late 2013 13" (256 GB SSD)


enter image description here


Try this:

  1. Reboot Into recoverymode
  2. Select disk utility
  3. First try to use first aid on your drive
  4. And then use first aid on each partition.
  • Already tried it, but it says that everything's ok.
    – M. Pater
    Oct 17 '16 at 1:23
  • Can't edit last comment. I also tried this solution without success. apple.stackexchange.com/questions/148473/… Thanks btw!
    – M. Pater
    Oct 17 '16 at 1:25
  • 1
    Try to create a new partition by splitting up one, did you do step 3? Do you have a Time Machine backup?
    – Harcker
    Oct 17 '16 at 5:32
  • I don't think that it'll work, and I may end up losing more disk space. I do have a Time Machine backup, maybe I should do a clean Sierra install.
    – M. Pater
    Oct 18 '16 at 4:05
  • I read that what you're telling me to do may work, some people said that they just splitted one partition and the new partition became bigger (letting them use all their disk space). Do you recommend me to do this on Recovery Mode?
    – M. Pater
    Oct 21 '16 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .