1

Model: Macbook Air (11", Late 2010, 1.6 GHz)

OS: El Capitan 10.11.6

Problem: Whenever I try to shut down or restart my Mac, Finder crashes and then nothing else happens. The computer continues to function, except without Finder. The menu bar disappears until I start another app (from the dock). I've tried relaunching Finder from the dock but nothing happens. I've also tried relaunching it via command + option + esc but that doesn't work either. The only way I can bring Finder back is to force restart the computer by holding down the power button.

There are some other odd symptoms, too, like that whenever I get a notification for an update I'll click update and then nothing will happen. I've found that when I restart and get to the login screen I can shut down and restart normally from there.

Besides these things the computer functions normally. I just can't get it to shut down or restart normally.

Any ideas of what might be going on? I can paste an EtreCheck if that would be helpful. Thanks in advance.

Note: What I'm experiencing seems to be identical to the problem described in this unanswered question. As recommended by a commenter, I've tried creating a new account but it has the same problems I've described above.

  • How long have you had this problem? Did it happen to coincide with some other event (crash, update, etc)! And, do you have Time Machine backups? – Monomeeth Oct 16 '16 at 1:46
  • I have Time Machine backups, but I'm not sure when the problem started - on the order of weeks rather than months. I'm not aware of any change I made to cause the problem. I just noticed that it started crashing. Thanks for helping me look into it. – Alex Johnson Oct 16 '16 at 2:29
1

Okay, I figure you have two options.

OPTION 1 - Delete Finder preferences

Let's delete Finder preferences first and see if that solves your problem. Since you can't launch the Finder, you will have to do this using the Terminal. Follow these instructions:

  1. Open Terminal (it's in the Applications > Utilities folder).
  2. Delete the primary Finder preferences file by typing this at the Terminal prompt exactly as I've typed it: rm ~/Library/Preferences/com.apple.finder.plist
  3. Press Return
  4. Since you're running El Capitan you will also need to delete the preferences for the Finder Sidebar by typing this at the Terminal prompt exactly as I've typed it: rm ~/Library/Preferences/com.apple.sidebarlists.plist
  5. Press Return
  6. Log out, then in again.
  7. Empty the Trash.

Hopefully this solves the problem. If not, proceed to Option 2.

OPTION 2 - Replace the Finder app

  1. Manually go to your Time Machine backup drive.
  2. Select a backup date you know was after you updated to El Capitan 10.11.6 and before you started having problems.
  3. Within your backup drive, navigate to the Finder app. This should be located at: Backups.backupdb > 'your computer' > 'backup date' > Macintosh HD > System > Library > CoreServices > Finder (Note: Your HD may be a different name to Macintosh HD).
  4. Double-check that the version of Finder is actually 10.11.4 (that's the version for El Capitan 10.11.6).
  5. Select and Copy the Finder app.
  6. Now, navigate to the CoreServices folder on your main HD. This should be located at: Macintosh HD > System > Library > CoreServices (Note: Your HD may be a different name to Macintosh HD).
  7. Paste the Finder app into this location.

Hopefully this solves the problem. If not, you could try Option 1 again now that you've replaced the Finder.

Let us know how you go.

[EDIT]

Option 3 - Test Startup/Login items

Okay, I'm adding this option based on the fact that the Finder seems to operate normally when your computer starts in Safe Mode.

This tells me it's likely to be something that's getting loaded during normal startup (e.g. a Startup/Login item, a font you've installed) that's causing the problem.

So I would now startup normally and go to System Preferences > Users & Groups. Take a note of your Login Items and then remove all of them and restart your computer (Finder should still crash) so that it starts again without those login items loading. Test this and see if the problem persists.

If the problem does persist, I'd then remove any fonts you've installed yourself.

Let me know how you go.

  • Thanks for the suggestions. A couple questions: 1. Does this remove the Finder preferences file for my particular account? Or for all accounts on the computer? For the record, the same problem exists for all accounts created on the computer. 2. Should I replace these preference files if they don't fix the problem? Or can I just rely on them being automatically regenerated? – Alex Johnson Oct 16 '16 at 5:34
  • The instructions I've provided in Option 1 will remove the Finder preferences file from the User's account only (these preferences are unique to each user). As far as the preferences file itself is concerned, it will be automatically recreated the next time Finder launches. My instructions for Option 2 will actually replace the Finder app itself (which is for all users). – Monomeeth Oct 16 '16 at 5:58
  • Option 1 didn't work, but I did discover that the computer shuts down properly when I'm booted into Safe Mode. Does that tell us anything? (For the record, I'd like to avoid replacing Finder unless as a last resort.) – Alex Johnson Oct 16 '16 at 7:09
  • I've also found that if I boot up and then restart or shut down from the login screen (i.e., before I've logged into my account), that works fine too. – Alex Johnson Oct 16 '16 at 9:08
  • Just added an option 3 for you to try. – Monomeeth Oct 16 '16 at 11:04
1

I've learned that this specific problem can have many different causes. Mine appears to have been caused by an old install of ProTools. Following the directions in this answer fixed my restart problem.

0

I had the same problem yesterday. Suddenly my machine tried to shut down but remained in a black screen... Hard booted (by keeping power-button pressed fir ~5 seconds) and after the O/S booted finder kept crashing, showing a crash-report dialog. Click the dialog away and it would crash again.

Launching anything (e.g. a terminal) without a working finder or menu-bar is problematic. Cortana wasn't working, neither was much of the config-settings screen, nor spotlight. Booting in safe-mode resulted in the same finder crash.

I solved it by rebooting the mac and keeping COMMAND+R pressed until the logo appears. It then will give you the option to reinstall macOS. Leave the partitions as-is (do NOT deleted them) and then simply reinstall the OS (just take "the same" as which was installed - in my case macOS Sierra). Took ~30 minutes and afterwards my data and apps were still there, same for the user-account. I could simply login to my existing user-account and everything was fine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .