19

I have a PDF document with a lot of notes. There is a yellow square in every note, and if I remove the note using the inspector, the yellow squares doesn't go away:

enter image description here

I need to print this document and it's unusable with all these yellow squares. How do I remove them?

PS: I already removed the notes, but there are still yellow squares.

2

6 Answers 6

25

Here is how you can remove the notes from the linked document.

  1. Open the linked document in Preview.
  2. control click on the note icon and select Delete Annotation.

Or:

  1. Open the linked document in Preview.
  2. Click the note icon, which opens the note.
  3. Press the esc key to dismiss the note but leave the note icon highlighted.
  4. Press the delete key.

Or:

  1. Open the linked document in Preview.
  2. Click: Preview > Tools > Show Inspector
  3. Click: Annotations Inspector
  4. Click the Type column, so all the notes are at the top.
  5. Select all the notes, then press the delete key.

Annotations Inspector

I've uploaded a modified copy of the linked document here.

8
  • 1
    I already deleted the notes, the problem is that the yellow square doesn't get deleted if I delete the note. Oct 16, 2016 at 11:25
  • 1
    @Ramy Al Zuhouri, All I can say is, I downloaded the linked PDF document, opened it in Preview and tested the three methods I've presented in the answer and in all cases the note icon was deleted along with its yellow color. Nothing was left behind from the deletion of the notes. The only yellow remaining in the document is in the signature field however this is not a note nor did I see a way to change it. I've uploaded a modified copy of the linked document here. Oct 16, 2016 at 12:56
  • 3
    I've found out what was the problem: if I delete a note, the yellow square doesn't disappear. But if I save, close and reopen the document I don't see it anymore. It's probably a bug. Oct 21, 2016 at 23:03
  • 2
    None of these methods are working for me.
    – tparker
    Sep 21, 2020 at 16:29
  • 2
    Third option worked for me Dec 17, 2020 at 17:47
6

None of these solutions worked for me, but probably because I was using a windows keyboard, which others might have. So maybe this will help someone.

With a windows keyboard what worked was to:

If the yellow square is now minimized to a small square, just click it once and then click the BACKSPACE key... NOT the DELETE key.

So backspace is the action you want, not forward delete. Coming from Windows this change in backspace vs delete when using a native MacBook pro keyboard was a little confusing.

*** NOTE - If the yellow square is opened large, just click anywhere outside of the square and it will shrink to a small yellow square, and then you can do as I said.

4

I figured it out! Move it and then press "delete" without clicking anywhere else. You have to move it instead of trying to select it

2
  • Thank you! This has been driving me crazy. Jul 26, 2021 at 0:15
  • Old problem, still not fixed by Apple. Thanks for that trick, made my day! BTW: It seems to be only the very last note that fights deletion. All other notes can be easily deleted with backspace in the annotations side bar. Jan 27 at 14:58
2

I had this happen just now and nothing worked. I had to first quit preview, then re-open the document. Then I could delete the yellow boxes using "Delete" as expected.

This is on Preview Version 11.0 (999.4)

1

MacOS 10.14.1, preview v10.1

For me the yellow boxes stayed on the screen.

The only way for me to remove them:

  1. selecting the note (a gray line appears around the yellow box)
  2. press Fn-Delete
0

My system is macOS 11.1 and I came across the same bug.

I have tried @Jess's solution ("However, I was able to delete the comments in another PDF viewer (PDF Guru), so I think this is a bug in Preview.") which works pretty well. The app I used was WPS office which could open nearly all kinds of files, for example, Word, Excel, Powerpoint, PDF, Mindmap files, just name a few. And it is free by the way.

Hope this could help you guys.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .