2

When I try to open Keychain Access using Spotlight or Finder, I see an error saying: The Application "Keychain Access" is not open anymore. When I try to launch using open -a, I get:

$ open -a Keychain\ Access.app/
Unable to find application named 'Keychain Access.app/'

It was working fine until yesterday. A restart did not seem to help.

Screenshot of image showing the Finder error message

Update:

It looks like I shouldn't rely on Terminal's autocomplete while using open. Removing the trailing slash did not fix it. The new error is:

$ open -a Keychain\ Access.app
LSOpenURLsWithRole() failed for the application /Applications/Utilities/Keychain Access.app with error -600.

Update 2:

Somehow it got fixed on its own. Among the things I tried was a restart, opening the app via the Terminal, and removing the plist from ~/Library/Preferences. None of those seemed to have had an immediate effect, if any at all, but Keychain Access is finally opening for me.

3
  • error -600 means no eligible process with specified descriptor maybe keychain app is corrupt? Have you an earlier version (from backup for example?) – dante12 Oct 17 '16 at 21:12
  • Unfortunately, Time Machine was not enabled on my machine. – Anand Oct 17 '16 at 23:32
  • I think the problem isn't your keychain itself but corrupt files. Try to boot into Internet Recovery CMD + Option + R open disk utility and try to repair your drive. If doesn't work you need to reinstall maOS. Download from App Store and install - update current system does not affect of your personally data. – dante12 Oct 18 '16 at 0:33
1

Lose the /.

$ open -a Keychain\ Access.app

works for me. Or even:

$ open -a Keychain\ Access

0

Note: no "/" at the end - works perfectly fine for me too.

$ open -a Keychain\ Access

Terminal must have been reading it as part of the fine name or something similar.

0

Copy com.apple.keychainaccess.plist from here: /Users/YourName/Library/Preferences to some safe place and then delete it from the original location. Then try to launch Keychain Access again.

1
  • Already tried that. Did not help. :( – Anand Oct 17 '16 at 23:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .