1

Config:

  • Me: Late-2013 rMBP running 10.12 (16A323)
  • Me: iPhone 5 running iOS 10.0.2
  • Me: iPad 2 running iOS 9.3.5
  • Wife: Mid-2013 MBA running 10.9.5 (criminy, I had no idea she was that far behind!)
  • Wife: iPhone 5 running iOS 10.0.2 (on same Sprint family account)
  • Wife: iPad Mini running iOS 8.2 (wow, she really doesn't like to update…)

Issue: When sending a(n i)Message to my wife in Sierra's Messages app, it actually sends it back to my account. When sending a(n i)Message to her in iOS's Messages app (on my iPhone or iPad), it sends correctly. I also do not appear to have any issues with using Sierra's Messages to send messages to anyone else.

What I've Tried: Searching (here, Google) pretty fruitlessly. (Would love it if Apple reconsiders naming apps after generalized terms)

This only started happening last night - to the best of my knowledge no related or tangential settings have been changed on any of our devices that would've prompted this.

  • If I do a new message, searching on my wife's name in (Sierra) Messages and select either to use her cell number or email address, everything looks good (her avatar shows as well as her contact info) - but once I send the message, the avatar in the left rail reverts back to me … and I get my own message (and she does not).
  • If I scroll back within my own messaging history to myself, I don't see any of our past exchanges before this started happening.
  • If when doing a new message by searching on my wife's name in (Sierra) Messages and her avatar comes up (as above), the messaging history is actually mine messaging with myself.
  • Quitting and restarting has no effect, as does rebooting.

It appears as though my messaging history with her is gone as far as Sierra's Messages is concerned, but doing a Spotlight search will find my chat transcripts with her.

Does anyone know any troubleshooting steps for Messages (such as analogous to rebuilding the iTunes DB)? I'm completely at a loss and given the app's name trying to search for anything meaningful is largely a fool's errand (unless someone has some serious Google-fu knowledge they can drop).

Thanks much in advance!

1

I had this issue and your solution didn't fix it for me. It drove me nuts. Deleting my Messages database is what eventually fixed it (note: your message history will be gone on your mac but still available on your iOS device):

  1. In Messages.app , go to Preferences -> Accounts and sign out.
  2. Quit Messages.
  3. Kill the IMDPersistenceAgent process via Terminal with killall IMDPersistenceAgent^
  4. In Finder, use the key combination Command-Shift-L to browse to the Library folder
  5. Rename 'Messages' to 'OldMessages' (I didn't want to trash it but you can if you like).
  6. Cleared the preferences cache by running killall cfprefsd in Terminal^
  7. Restarted my mac
  8. Opened Messages again. I sent a test message, and this time my wife received it (and I didn't).

^Commands came from this article

UPDATE I had this issue again today (2017-08-09), and again the steps above cured it for me at the cost of losing access to my message history on my MacBook. Curiously the issue appeared after upgrading the iOS version on my iPad (whereas the issue occurs on my MacBook; my iPad has never exhibited any messages-related issues).

I tried @brian-m's suggestion of moving the OldMessages folder back (after steps 3 and 6 above); sure enough I can see my old messages just fine but the original problem is immediately reintroduced. So it's some sort of database issue. I had a bit more of a poke around and can see it's a SQLite database. There's a good discussion of the schema here. Unfortunately I don't have time to delve further.

  • Interesting. Sorry you had the same maddening experience. Have you tried moving your OldMessages/ contents back to the new Messages/, giving you back your history? I'm really curious about whether the history is really the root problem with this confounding issue. (In any event, thanks for contributing your answer!) – Brian M. Apr 19 '17 at 15:44
  • @BrianM. No I haven't; I'll do so at some stage but it'll probably be a while before I get around to it. I suspect there's configuration in that folder, not just history. Anyway thanks for sharing your solution too, it was certainly worth a try. – cobberboy Apr 20 '17 at 15:58
  • 1
    I can completely relate to not wanting to run the risk of hitting your head on this all over again. ;-) Good to know about this option should it happen again. – Brian M. Apr 20 '17 at 16:51
0

Further research turned up nothing (either cause or potential fixes). Finally wound up resolving it by:

  1. Signing out of iCloud (and deleting local contact data) on my MBP
  2. Rebooting
  3. Signing back into iCloud

I've confirmed not only messaging her from my MBP does in fact reach her and not boomerang back to me, but also that my full messaging history with my wife appears intact on my MBP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .