40

macOS Sierra is constantly displaying an "Enable Siri?" dialog. If I pick cancel it just pops up again 5 seconds later.

enter image description here

How do I tell macOS Sierra to stop asking?

6
  • 2
    Have you tried enabling it, then going into System Preferences and turning it off?
    – user11633
    Oct 14, 2016 at 23:39
  • 1
    that seems to have done it .. crossing my fingers
    – gman
    Oct 15, 2016 at 1:54
  • Please ask a new question for the earpod problem as the answer may likely be different and it is kind of confusing of having both topics mingled into one.
    – nohillside
    Nov 6, 2016 at 19:20
  • Or check apple.stackexchange.com/questions/252259/… first which seems to cover that already.
    – nohillside
    Nov 6, 2016 at 19:22
  • This is almost a duplicate apple.stackexchange.com/questions/258816/…
    – William
    May 8, 2017 at 16:48

2 Answers 2

49

If you've been mistakenly triggering the Siri pop-up when your finger mistakenly hits the top right area on the Control Strip, you can remove the Siri icon.

Go to:  → System Preferences → Keyboard, then click the "Customize Control Strip" button on the bottom, or on newer OS X, "Touch Bar Settings" then "Customize Control Strip"

Move your cursor to the Control Strip (which will now be in Edit Mode), and click and Drag the Siri Icon back onto your screen into the area with all the unused Control Strip widgets.

7
  • This is correct. Nice one. Oct 1, 2017 at 20:55
  • 3
    Thanks, this did not only solve my problem, but also brought to my attention that there's useful stuff I can add to the touch bar.
    – Huluk
    Nov 12, 2017 at 21:57
  • 3
    would not let me drag items off the little taskbar in that dialog, instead the entire bar worth of default items was moving around.. but I could drag them around on the taskbar itself when in that mode, so dragged the siri icon to the far left to get it away from the fingerprint reader .... that is the least user friendly config screen I've seen in a while. Jul 25, 2018 at 19:34
  • Awesome. That's a really useful feature. Wish Apple had put half as much effort into making that discoverable as they put into making Siri available in Mac OS. I replaced her with a button to pull up the launch pad.
    – Chris
    Jul 29, 2018 at 19:08
  • 2
    @ChuckvanderLinden that's what I had to do... to be more specific, I dragged it into the trash can.
    – ajb
    Dec 17, 2018 at 21:00
4

Accept by clicking Enable Siri, then go into System PreferencesSiri to uncheck Enable Siri. That should take care of it.

3
  • 7
    This does NOT end it. Pressing the Mic button accidentally, will trigger the whole cycle over again.
    – jnovack
    Nov 10, 2016 at 14:56
  • 1
    THIS DOES NOT WORK Apr 27, 2017 at 14:06
  • 3
    This worked nicely and addressed 2 different things that were triggering the prompt.
    – doub1ejack
    Mar 12, 2018 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .