For some reason app store simply does not work:

enter image description here

Solutions like:

  • reset NVRAM;
  • remove com.apple.appstore.plist, com.apple.storeagent.plist and then restart,

did not solve the problem.

Does anyone know other possible solutions?



TLDR: If you can browse the web with Firefox or Chrome, but not with Safari, then adjusting your network settings might fix both Safari and the App Store. Start by looking at proxy settings.

I'm hoping you found a solution by now. Just in case this helps anyone, I'm going to share what worked for me. I had no problem browsing the web with Firefox or Chrome, but the App Store just showed a grey window like the screenshot in the original post.

During troubleshooting, I discovered that Safari couldn't connect to any web servers. This suggested that the problem had something to do with the Mac's network settings. I opened the network settings, selected my network adapter, clicked Advanced, went to the Proxies tab, and unchecked Automatic Proxy Configuration. That fixed everything.

  • Hello. Thanks for your effort, but it still does not work for me. Actually, I can browse with Chrome, Safari, Firefox - all browsers work fine. The problem is with app store only. Yep, maybe it due to proxies, but everything worked before and suddenly stopped, and that's interesting. – Gino Pane Oct 19 '16 at 8:23
  • Yep, it was because of proxy. Thx. – Gino Pane Oct 19 '16 at 14:06
  • I'm glad it's working now. – mrog Oct 19 '16 at 17:20

Here is a tutorial from a guy who fixed what seems like the same issue you are experiencing:
Check this out

I also recommend you change your time zone to anywhere but your current location, restarting and then choosing "Set time zone automatically using current location" (Date & Time Preferences). Many times this resolved a few Mac OS (X) issues for me.

Let me know how you go.

  • Thanks, but unfortunately nothing works fo me. – Gino Pane Oct 16 '16 at 16:57

You must log in to answer this question.

protected by Community Mar 21 '17 at 2:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .