I'm trying to install Windows 10 on its own partition, based on this guide.

When I try to install the "rEFInd" utility, it warns me that it can't install because SIP is active, and that I should reboot to recovery and install it from there.

But when I try to reboot with Command-R or Command-Option-R I get the icon below, then a normal boot.

The MBP is running 10.11.4.


As requested by David Anderson:

MBP:~ zeev$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *240.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS mbp1                    179.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data BOOTCAMP                60.0 GB    disk0s4

MBP:~ zeev$ sudo fdisk /dev/disk0
Disk: /dev/disk0    geometry: 29185/255/63 [468862128 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [    409640 -  349995408] HFS+        
 3: AB 1023 254  63 - 1023 254  63 [ 350405048 -    1269536] Darwin Boot 
 4: 0B 1023 254  63 - 1023 254  63 [ 351676416 -  117184512] Win95 FAT-32

MBP:~ zeev$ sudo gpt -r show /dev/disk0
gpt show: /dev/disk0: Suspicious MBR at sector 0
      start       size  index  contents
          0          1         MBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  349995408      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  350405048    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  351674584       1832         
  351676416  117184512      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  468860928       1167         
  468862095         32         Sec GPT table
  468862127          1         Sec GPT header
  • Stop what you are doing and updated your question with the output from the following commands. These commands will not change your computer. diskutil list, sudo fdisk /dev/disk0 and sudo gpt -r show /dev/disk0. Does your optical (DVD) drive work? If Windows 10 will run on your model, we will get it installed. Also, do you know how much memory is installed? Oct 13, 2016 at 17:58
  • 1
    Did you get Windows 10 installed? Oct 18, 2016 at 18:42
  • I am first trying to install windows 7. Got the drive partitioned with boot camp but I don't have a DVD so trying to find way to install from USB. It rebooted into Windows with dos_like black screen "no boot disk". Holding option does not show USB.
    – Dan
    Oct 18, 2016 at 20:33
  • Also I added the output of those commands you mentioned above.
    – Dan
    Oct 18, 2016 at 20:41

2 Answers 2

  1. When you are running 10.11 and you need to restore the Recovery partition, read here how to do that: http://osxdaily.com/2016/07/03/recreate-recovery-partition-mac/
  2. do not try to install Windows without Bootcamp !! You do not need to disable SiP when you install Windows correctly.
  • According to this table at Apple.com the "latest" version of Windows I can install on this Core 2 Duo machine is Windows Vista 32-bit ... which I find hard to believe. Hence that guide I linked on Reddit which claims otherwise. Also, when I ran Boot Camp Assistant, it failed to even recognize the blank FAT-formatted 32GB USB stick I had attached.
    – Dan
    Oct 14, 2016 at 13:25
  • 1
    @Ze'ev: The table shows you can run 64 bit Windows 7 on your model Mac. The table also show the "Boot Camp Support Software" (BCSS) is version 4.0.4033. This is the version you probably should use to install Windows 10. You have to look at it this way: If you installed 64 bit Windows 7 using version 4.0.4033 of the BCSS and later you upgraded to Windows 10, then Windows 10 would be using this version of the BCSS. So skip installing Windows 7 and just install Window 10 using version 4.0.4033 of the BCSS. Any newer version will probably not work properly with your model Mac. Oct 14, 2016 at 15:05
  • @DavidAnderson: Maybe I'm reading the table wrong. I got this laptop in Early 2008 ... identified as "MacBookPro4,1" and "Intel Core 2 Duo 2.5 ghz" -- so, on the table, is that "MacBook Pro (17-inch, Early 2008)" or "MacBook Pro (17-inch, Core 2 Duo)"? Very confusing.
    – Dan
    Oct 17, 2016 at 10:56
  • 1
    @Ze'ev: I believe you should use "MacBook Pro (17-inch, Early 2008)". I updated my posted answer. I hope this will make the table less confusing. Oct 17, 2016 at 18:27
  • The software linked in that article - Recovery Partition Creator - worked, I now have a working recovery.
    – Dan
    Oct 19, 2016 at 7:31

Answer to Your Posted Question

The output you posted does not indicate any errors in the partition tables. Therefore, I do not know why you can not boot from the internal drive Recovery partition. Some possible causes

  • The GPT attributes are incorrectly set for the Recovery partition. The correct value is 0x2000000000000. You can the command gdisk to view the attributes and correct any errors.
  • The Recovery partition filesystem has been corrupted.
  • The Recovery partition files have been corrupted.

Actually you do not have to boot to the Recovery partition to disable SIP. The web page Getting rEFInd form Sourceforge has a link where you can download "A USB flash drive image file". You can then use the dd command to copy the refind-flashdrive-0.10.4.img file to a USB flash drive. The exact commands that I entered are shown below. Caution: You may need to substitute disk1 with a different device.

cd ~/Downloads/refind-flashdrive-0.10.4
diskutil unmountdisk disk1
sudo dd if=refind-flashdrive-0.10.4.img of=/dev/disk1

You then can restart your Mac and hold down the option key to invoke the Startup Manage. Select the USB device icon labeled "EFI Boot" as shown below.


Next, select the shield icon labeled "Change SIP Policy", as shown below.


You get the pop up message "System Integrity Proection is disabled (0x77)", as shown below.


Previous Answer Regarding Installing Windows

You do not need rEFInd to install any version of Windows on any Mac that can officially or unofficially support the version of Windows you are trying to install.

If you examine the Apple web site About EFI and SMC firmware updates for Intel-based Mac computers, you can determine the mapping between the MacBook Pro models and identifiers. I listed a few below. This should clarify which entry in the table "Boot Camp requirements by Mac model" belongs to your model Mac.

MacBook Pro (17-inch)              = MacBookPro1,2
MacBook Pro (17-inch, Core 2 Duo)  = MacBookPro2,1
MacBook Pro (17-inch, 2.4 GHz)     = MacBookPro3,1
MacBook Pro (17-inch, Early 2008)  = MacBookPro4,1

Boot Camp Support Software 5.1.5722 is the wrong version for your model Mac. You should be using version 4.0.4033.

If your Mac can run Windows 10, the you will probably need a working optical (DVD) drive. If yours is missing or inoperative then you can still attempt to install but the procedure difficult. You can not use a USB flash drive Windows 10 installer.

If you can not boot to your OS X Recovery partition, then either you do not have a recovery partition of the partition tables are messed up.

Your Mac is to old to use OS X Internet recovery. So using Option-Command-R is pointless.

Generally, the "Boot Camp Support Software" can be download to a USB flash drive though the use of the Boot Camp Assistant application. For the older model Macs, this software is often identical to the "Boot Camp Support Software" you would download using the Safari application for an old version of Windows.

Therefore, most likely you can install Window 10 on you model Mac without the aid of the Boot Camp Assistant application. So if this application is giving you problems, the you may be better of not using it.

  • When I ran Boot Camp Assistant, it failed to even recognize the blank FAT-formatted 32GB USB stick I had attached.
    – Dan
    Oct 14, 2016 at 13:27
  • 1
    @Ze'ev: Well, I did post in bold letters that you can not use a USB stick. Yet it should be possible to install Windows 10 anyway. My machine is a mid 2007 iMac and I am running 64 bit Windows 10. If you have more questions, just ask them. Oct 14, 2016 at 13:43
  • If I don't have a DVD, and don't use rEFInd, how would I install Windows?
    – Dan
    Oct 18, 2016 at 20:41
  • 1
    @Ze'ev: In the event you do not succeed in installing Windows, I will leave you with this link: Installing Windows 7 Pro 64 bit without DVD or Flash Drive. The outlined proceedure could be used as a last resort. Oct 19, 2016 at 8:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .