3

I have been using the Preview.app that comes with Mavericks until El Capitan.

The reason that I have been copying that application instead of using the newer version is that it works better for my workflow and for a lot of other people, such as here, here, and here.

I have been copying the version on every system upgrade without any problems but it seems this can't be done with Sierra.

Is there a way I can get this app to run on newer macOS Sierra or some other clone of this app I can use?

Console.app show this error:

Application failed to launch (id = com.apple.Preview, version = 7.0 reason = kLSIncompatibleApplicationVersionErr)
OSActivityID: 0x800000000034078c
com.apple.message.domain: com.apple.launchservices.launchfailures.oldAppVersion
com.apple.message.signature: com.apple.Preview - 7.0
com.apple.message.result: failure
SenderMachUUID: C10E9E98-E1E0-3795-A40C-252F709E6C93
  • Try following: Open your programs folder. Choose preview.app and from the context menu (right click on the app) - choose show package content. Open the contents where you find info.plist. Open this file with Xcode for example. Change the entry Minimum system version to any earlier macOS Version for example the last system version that you work with preview. Save it an try whether works. Please make a backup before changes! – dante12 Oct 13 '16 at 13:10
  • @dante12 Thanks, but it didn't work – José F. Romaniello Oct 13 '16 at 13:35
  • I don't program in Obj-C, but I'm willing to bet that an error return of kLSIncompatibleApplicationVersionErr is not a barrier than can be overcome by the user. – tubedogg Oct 13 '16 at 19:36
1

Copy the old Preview and rename it (for example Preview_old), so you have two Previews in the Application folder. If the Preview_old gives the same failure and does not run, do the change as dante12 posted.
You have to change the GetInfo "open with" field to Preview_old for the relevant files.

  • /Applications/Preview_old.app/Contents/Info.plist has "LSMinimumSystemVersion" equals to 10.9.0 while the new app has 10.10.0. What should I put there? Thanks – José F. Romaniello Oct 17 '16 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .