1

I installed Sierra OS on my iMac without any troubles. But, when I open Terminal, I can't scroll through the bash history when pressing the up arrow.

  • I am assuming you mean, "scroll through the bash history when pressing the up arrow." Is that correct? – Allan Oct 13 '16 at 12:07
1

Have a look at /etc/bashrc_Apple_Terminal. The file contains comments that explain how to disable bash_sessions:

# The save/restore mechanism is disabled if the following file exists:
#
# ~/.bash_sessions_disable

or just disable their shell history mechanism

# You may disable this behavior and share a single history by setting
# SHELL_SESSION_HISTORY to 0. There are some common user customizations
# that arrange to share new commands among running shells by
# manipulating the history at each prompt, and they typically include
# 'shopt -s histappend'; therefore, if the histappend shell option is
# enabled, per-session history is disabled by default. You may
# explicitly enable it by setting SHELL_SESSION_HISTORY to 1.
0

You can perhaps also restore the (hidden) .bash_history file from the TimeMachine backup Found in the HomeFolder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .