12

I never experienced something like this before I upgrade to macOS sierra a few days ago. At first, I didn't notice it, but after a while, it becomes annoying as hell.

Begin

Mission Control

After selected a window from mission control, or just dismiss it (press esc), it just lost focus of Finder and switch to another random apps (Skype, Chrome, XCode, blah blah...)

How to fix this?

Update:

This not only happened to Finder, but System Preference and sublimeText as well. Probably more apps might affected by this issue. But some apps (xcode, skype, chrome...) are not affected. I'm so confused....

Update 2: I've found the reason, but it's not satisfied me!

The reason for this lost focus is because I've set the option of Finder in dock assign to all desktop:

Desktop assignment

It won't lose focus anymore if I set it to a specific desktop. However, I'd like to have all Finder in all desktop as I used to it before :( still annoying.

  • I can't see "Options" when right clicking finder in docker, how did you find enable it? – Dan Andreasson Dec 19 '16 at 22:47
  • @DanAndreasson I dunno, it's already ever since I use OSX. Just right click any app in the docker. How about you provide a screen shot in your case? – Eddie Dec 20 '16 at 10:30
  • 2
    Thanks for posting this question. I have the same problem and I couldn't figure out what was causing it until I read this. This is annoying and I hope Apple fixes this soon. – j.c. Dec 27 '16 at 22:31
  • 1
    This is the problem I'm experiencing: apple.stackexchange.com/questions/329116/… – Arnold Roa Jul 1 '18 at 17:32
  • This issue was affecting a variety of applications. I tried your advice and assigned the affected apps to "This Desktop" and it fixed the problem. I think the issue is a MacOS bug triggered by the on-chip GPU and the discrete GPU. – Twitch Sep 5 '18 at 15:11
2

I'm having exact the same issue, and it took me weeks to define it, while it was driving me crazy. Its clearly a bug, and the update 10.12.1 didn't work. But, there might be another solution. I've followed your advice and assigned finder and safari to different desktops, it works but its not the way it should be. However, assigning finder and safari to NONE works!!! I've tried to juggle with a few different apps and so far so good

  • 1st: This isn't actually an answer. 2nd: the solution you mentioned is found by me, and that's not what I want. I want my app's windows the same for every desktop I have, and doesn't lost focus from "application windows" event. – Eddie Nov 8 '16 at 18:09
1

Another solution: safari None, finder All desktops and...deactivate "Displays have separate spaces" in mission control window.

Mission Control Settings

0

I assigned finder and safari to all desktops. Now it's reversed, safari stays on the back...

BUT... my finder widows are always smaller than safari's, so it worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .