1

My son pulled out the USB cable while iPhoto was running from the external hard drive and a message came up when I plugged it back in that said there were inconsistencies that needed to be repaired. So I followed the instructions to complete it but it didn't work.

Next I used a new external hard drive to make a back up of the MacBook and a copy of the iPhoto Library.

Then the iPhoto Library msg said that it was either being used by another user or unreadable. I saw that there were 4 other options if you opened iPhoto while pressing command-option.

Once copied I tried to open the copy but kept saying it was unreadable still. Restarted etc., didn't work again. Tried the first option, repairing permissions... didn't work, next tried option 3, but then the message came up saying that it would only be available once Time Machine had finished. But Time Machine isn't on!

I'm not sure what to try next.

  • Welcome to Ask Different. When you say you "followed the instructions but it didn't work", can you explain how you know it didn't work? Did you get any error messages? – fsb Oct 12 '16 at 22:15
  • Can you clarify whether you do have any TimeMachine backups or not? – Monomeeth Oct 13 '16 at 0:20
  • Once I tried to repair the inconsistencies i know it didn't work as a new error msg came up – Kate Oct 13 '16 at 2:26
  • Msg said...your photo library is either in use by another application or has become unreadable. – Kate Oct 13 '16 at 2:28
  • I made a time machine back up (onto a new EHD) after the iPhoto library didn't work. The library is on the external hard drive though, not on the MacBook. Wasn't sure that a back up would help but did one anyway. Then I made a copy of the iPhoto library from existing EHD to the new EHD, that I'd just made a back up on. Once I had the library copy, I used that version to try the repairs and that's when a msg came up saying that the library would be available when time machine was finished. (But I switched TM off before starting repairs) – Kate Oct 13 '16 at 2:30
1

It sounds like you made a copy of the library after it was corrupted. Your only option I suppose is to grab the images and start a new library.

Find the original, if possible, right click on it and choose "Show Package Contents".

enter image description here

In there navigate to "Masters". In there, run a search for Kind=Image.

enter image description here

Copy all of the results out of there, to a safe location. Then do another search for Kind="Movie", and copy those as well.

enter image description here

  • Should I do that to a separate drive to where I have done the time machine back up? – Kate Oct 13 '16 at 5:16
  • If you create a new Photos library, you could just drag and drop the results into the new library window. – Jules Oct 13 '16 at 5:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .