32

Since the upgrade to macOS Sierra I occasionally see a service CalNCService running hot (i.e. on 100% CPU). So going from the name, this seems to be some Calendar Service. I tried disabling Calendars in Internet Accounts Preferences, but this was no help. One can kill the service or restart the computer, but the problem persists. Usually, after a few hours or so it goes back to normal.

What is this daemon doing? How can I debug this issue?

Update: In the log console I find this when calNCService starts up:

warning: dynamic accessors failed to find @property implementation for 'serialNumber' for entity ABCDAddressBookSource while resolving selector 'serialNumber' on class 'ABCDAddressBookSource'.  Did you remember to declare it @dynamic or @synthesized in the @implementation ?

Update2: The Service is connected to syncing reminders. Disabling reminder sync under Internet Accounts makes the service go back to normal, enabling it again makes it go back to 100%. This seems independent of the server. I have a bunch of recurring reminders and first had this problem with my account on fruux.com. Then I migrated all to iCloud and now its the same there.

Update3: Still very present in 10.12.1. and no reply on Apple Support Communities.

Update4: Another morning, another calNCService. I have also manually checked the exported .ics of the offending reminder list. It looks totally harmless. About 40 Reminders with nothing special in them. calNCService after some uptime

Update 5: Still all the same in 10.12.2

Update 6: Confirmed in 10.12.4. Iterating: This seems to be some housekeeping task. When I activated the reminders after the upgrade the problem was not triggered for more than 24h. But now it is back. As before, it can be simply stopped by deactivating reminder sync under "Internet Accounts"

Update 7: The bug seems to be still present in MacOS 10.13 High Sierra, it is less severe, though. I have been letting the corresponding reminders account activated. During an uptime of 13 days CalNCService clocked in a CPU time of 1:07:01 (31h), way too much, but less than e.g. "kernel task" (7:16:16).

Update 8: Still present in 10.13.4. I have two machines with MacOS and it happens on both of them. It seems to be connected to reminders added via some API such when you add reminders via Launchbar. The CPU time of calNCService seems to be correlated with how much I use Launchbar or Siri to enter reminders.

  • 1
    The process is currently running hot and I disabled both (including quitting the applications) -> No change, still running hot. – Thomas Oct 18 '16 at 7:08
  • 7
    Whenever you see “NC” in the name of the service, this refers to the Notification Center part of it. Does this problem go away if you remove Calendar and/or Reminders from the Notification Center? In the past, any issues I’ve experienced with Reminders in the Notification Center were resolved by deleting all my Completed reminders (several thousand of them). – user11633 Oct 18 '16 at 19:36
  • 3
    @Phong Oh. This is very helpful information. I'm trying it out. Although clearing my about 3600 done reminders did not help with this issue. I've tried that. – Thomas Oct 19 '16 at 6:53
  • 1
    @Phong Alas, it does not help. Emptied my entire notification center (it did have "Reminders"), but no change. – Thomas Oct 19 '16 at 7:08
  • 2
    Out of the blue my own CalNCService started stampeding, and after trying everything I found online (i.e. disabling/re-enabling calendars and reminders, removing access by apps, restarting etc., more here: support.itsolver.net/hc/en-gb/articles/…), the last thing I did before CalNCService went back to normal was to remove ALL widgets from Notifications Center's Today tab (i.e still leave notifications in place). Couple minutes later, while I was doing spindump on CalNCService process, I realized it'd gone back to normal already. – user1559834 Nov 8 '16 at 0:28
10

I had same problem (fans at full throttle, CalNCService at 122% of CPU) and have made 2 visits to Apple store and 3rd visit I checked in the Mac for a warranty repair (replaced both fans)... Yet the problem continues.

I went into notifications > edit and disabled all notifications, badges, sounds, etc, except for iMessage, Slack and Outlook.

About 3 minutes later, I noticed.... silence. Fans are normal. I'll watch it for a while, but it seems this issue is definitely related to something in notifications. I won't miss being pinged all day long.

  • 2
    The fan replacement is preposterous. What kind of Apple store was that?? It's clearly a software problem. It's visible in activity monitor. – Thomas Mar 22 '17 at 9:03
6

Definitely works, even before restarting:

On your own risk! Do a Time Machine backup first.

  1. Open System Preferences, Internet accounts and untick Calendar for each account.
  2. Open Activity Monitor, search calendar and quit calendar processes.
  3. Open Finder > Go to Folder (⇧⌘G) /Library/Caches and drag contents to trash.
  4. Open Finder > Go to Folder ~/Library/Caches and drag contents to trash.
  5. Again, open Finder > Go to Folder ~/Library/Caches and drag contents to trash.
  6. Open Finder > Go to Folder ~/Library/Containers select com.apple.CalendarAgent, com.apple.CalendarAgent.CalNCService, com.apple.CalendarFileHandler and com.apple.CalendarNotification.CalNCService and drag to trash.
  7. Open Finder > Go to Folder ~/Library/Calendars and drag contents of the folder to trash.
  8. Restart your computer.
  9. Empty trash.
  10. Open System Preferences, Internet accounts and tick Calendar for each account.
  11. Open Calendar and wait for Calendars to sync.

Affected OS: macOS Sierra 10.12
Unconfirmed affected OS: Mac OS Yosemite 10.10 and El Capitan 10.11

From: https://support.itsolver.net/hc/en-au/articles/214098206-macOS-Sierra-CalNCService-high-CPU-usage

  • In case anyone is wondering, this kind of works. However, I think it's easier to just open the calendar app, go to preferences > accounts, and disable them all, then enable them back. It should fix it. NOTE: the step to delete ~/Library/Calendars seems like required. I guess the files gets corrupted or something – Cristiano Coelho Mar 4 at 23:36
4

I had similar problem. CalNCService was consuming enormous amount of CPU. Here is how to reproduce on my side:

I am using iPhone SE with iOS 11.1.2 and a MacBook with macOS High Sierra on the same Wi-Fi. I got a call on my phone, but I just did not accept it via Remind Later. After around 50 mins, I noticed my MacBook gone crazy.

The fix was to delete that call reminder from my phone, then MacBook cooled down immediately.

  • Welcome to Ask Different, and thanks for contributing! Mind that the answer field is only for answers to the actual question. While I feel your contribution does add value to the discussion, and also relates to the question to a certain degree, it does not answer it. The best fit for future contributions like that one would be to post them as a comment to the question, not as an answer. To gain commenting privileges, check out how to earn reputation points. Thanks and have fun! – Synoli Dec 3 '17 at 13:15
  • @Synoli how does the answer sound now? At least compared to other two answers which start with I had same problem... – guness Dec 3 '17 at 14:33
  • No biggie. The one thing I meant to point out is that the OP specifically asked for what the daemon is, what it does, and how to go about debugging it. They actually did not ask about how to fix it. But then again, the other respondents seem to have interpreted it the same way you did. So it could very well be that your answer is just fine, and that I was mistaken! – Synoli Dec 3 '17 at 17:45
  • I had the exact same scenario. Did not Accept it via Remind later, and after the reminder that stupid CalNCservices went crazy. Simply deleting the Reminder fix it. – user982438 Dec 21 '18 at 18:57
  • Thanks! Helped me on 10.14.5 – Nek Jun 3 at 7:24
1

I had to also ditch preferences & related files. There's an article that walked me through this, and my computer is quiet & cool-to-the-touch for the first time in weeks. Looks by the blog date like this predates Sierra: https://robert.accettura.com/blog/2012/08/19/how-to-stop-calendaragent-from-eating-cpu/

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Jan 8 '18 at 16:36
1

I unsubscribed to a german holiday calendar in my Calendar App. That worked immediately and the fans have gone silently again. I suppose this subscription in this calendar app was the problem. Hope that will help someone.

0

I first noticed this issue immediately after the very first time I created a reminder using Siri on my Mac (running High Sierra). Deleting this reminder made CalNCService behave right away.

I then recreated the same reminder without Siri, and CalNCService did not start acting up. So in my case it seems to be linked to creating a reminder with Siri on the Mac.

0

I had this problem as well. I tried the above suggestions without success. Here's what finally worked for me:

  1. Open System Preferences > Internet Accounts
  2. Select the iCloud account and uncheck Calendar & Reminders
  3. Select any Google accounts that you have and remove them (Click the "-" button, bottom left)
  4. Restart the computer
  5. Open System Preferences > Internet Accounts and re-enable Calendar & Reminders for iCloud
  6. Add your Google accounts

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .