2

Judging by the Rcvd Bytes column in Activity Monitor, storedownloadd has been busy downloading. It downloaded 2GBytes while my computer was on today, and earlier this evening it downloaded 424.1MBytes.

I'm assuming this is macOS Sierra, but that's not terribly important - I just want it to stop! What options do I have to set to do this?

I've played with the App Store settings a bit:

enter image description here

But this didn't seem to make any difference. I've rebooted, and softwaredownloadd is still downloading. 320MBytes now. Wait... how big is this thing?

(I'm reluctant to disable the automatic update check. I like to know when new updates are available. However I do insist on being allowed to schedule the download and installation myself.)

(Macbook Pro retina 13" early 2015, OS X El Capitan 10.11.6)

  • 1
    I'm having this exact problem; unfortunately the only way I was able to prevent the download is to disable "automatically check for updates". I'd say it's a bug. Btw, you can locate the download by running lsof -p PID, where PID is from Activity Monitor (or use Activity Mon's "open files and ports"). The .pkg is the one. After unchecking the pref, you can launchctl stop com.apple.storedownloadd and then launchctl start com.apple.storedownloadd. Remove the pkg if you want. – Kelvin Oct 13 '16 at 16:35
-1

You could try to unload the daemon

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.storedownloadd.daemon.plist

Or the best thing to do is pause the updates in the App Store

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .