2

Having a weird issue with a Mac mini.

At the end of the day, I perform a full shutdown. The main power is then turned off.

When the main power is turned back on again, the Mac mini is automatically turning itself on and starting up. I don't want it to do this.

Under the Energy Saver settings in System Preferences, start automatically after a power failure is unchecked. There is also nothing in the Schedule that would cause the machine to turn on.

Any ideas why my Mac won't stay off when the main power is reapplied?

EDIT - pmset -g output

Active Profiles:
AC Power        -1*
Currently in use:
hibernatemode        0
womp                 0
networkoversleep     0
sleep                20
Sleep On Power Button 1
ttyskeepawake        1
hibernatefile        /var/vm/sleepimage
autorestart          0
disksleep            10
displaysleep         20

EDIT 2

If I understand correctly, I will be resetting the SMC every day because the main power is removed from the machine. As per; https://support.apple.com/en-gb/HT201295

Could the fact that the SMC is being reset make the machine power on the next time main power is applied?

  • What does pmset -g (in Terminal) print? Also, have you tried resetting its NVRAM and SMC? – Gordon Davisson Oct 11 '16 at 16:49
  • @gordon added pmset -g output to original question. I believe so, is this not happening everytime the main power is removed for more than 15 seconds as per - support.apple.com/en-gb/HT201295 – David Oct 13 '16 at 8:06
  • Please go to system settings -> Energy Safer and check if the option Start up automatically after a power failure ist enabled. Disable it and test. – dante12 Oct 13 '16 at 8:22
  • @dante12 - please read the original post. Already mentioned that this is unchecked. – David Oct 13 '16 at 8:31
  • Ok there is not the right way but in /Library/Preferences there is an com.apple.PowerManagement.plist (may be different location of mine) check if the Automatic Restart at power loss is enabled - disable it.. Make a backup of of your old plist - file before you change anything. I reccomended you should Edit the plist file with an applicatively Editor or with xCode. – dante12 Oct 13 '16 at 9:02
1

Have you tried removing any usb such as external hard drives? That's probably the issue

  • 1
    Please add more to your answer, as here we look for high quality answers that explain why this would affect the boot process. - From review. – bret7600 Jan 26 '18 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .